Print Problem with Malyan M180

Hi There,

I have a printing Problem with my Malyan M180 printer. Normally i print with .x3g files from SD Card sliced by Simplify 3D. That works great, but i want to use Octoprint(octopi) for my Printer.

I already installed the needed Plugins (GPX, ...), the connection to my printer works fine, i can send the .gcode to the printer and it will start to print, but it looks like, Z is not moving down and so the print will be compressed.

Anyone an idea?

Hello @Vargur_Erikson !

So it is no plugin issue.

Please share the systeminfo bundle.

Also check the z-axis moving freely without issues. Of course not during print.

Hi @Ewald_Ikemann

If i use the z-down button in control it works fine but move up instead of down ... i also tested when i invert Z in my printer-profile, now moving is correct but for printing it doesn't matter

octoprint-systeminfo-20230302115137.zip (64.2 KB)

You have both, the GPX and the Malyan plugins installed.
You just need one of them.

Can you share the gcode file you like to print. If it is too large, you can zip it.

Please also enable the serial.log and try again.
After that please upload the updated systeminfo bundle.

@Ewald_Ikemann

now i have uninstalled Malyan Connection Fix, activated serial.log

octoprint-systeminfo-20230302125607.zip (105.3 KB)
S3DRailMountHelper-1x.gcode (283.7 KB)

All the commands are properly send to the printer, exept:

There is a warning during the start code:

2023-03-02 12:49:27,146 - Send: N8 G92 Z-5*120
2023-03-02 12:49:27,154 - Recv: ok
2023-03-02 12:49:27,156 - Recv: // echo: (line 8) warning G92 emulation unable to determine all coordinates to set via x3g:140 set extended position
2023-03-02 12:49:27,157 - Recv: // echo: current position defined as
2023-03-02 12:49:27,157 - Recv: // echo: X:171.41 Y:53.82 Z:-5.00 A:0.00 B:0.00

Maybe the first 5 mm are ignored...

Hi @Ewald_Ikemann

You mean i should delete the G92 line in the Code?

For a try you just can put a semicolon (;) in front of it.

Malyan firmware is somehow different than Marlin or Klipper

Excluding G92 did not help :frowning: ... same Problem ... i also tried to set "Recalc build progress" to yes in GPX settings... nothing helps

Does the file print from the printer's SD card - it it has?

You mean start printing the file from the SD card in Octoprint. Or do you mean copy the gcode file to the SD card and start it directly from the printer?

Yes, the second one.

GCode directly from printer does not work, because the printer does not recognize the file.

I found a Marlin FW for my M180, i will try this and give a feedback

1 Like

Hi Ewald,

I tried the Malyan Marlin FW from the Malyan Homepage, but this does not work (Printer did not work, after updating to original FW the printer works again)

It looks like the printer is moving down f.e. 0,2mm and instandly moving up f.e. 0,2mm, so the print base stands at the same place while printing

I more thought of such:


BTW: Is this Docker related?

I don't know how to get this from Github to my printer.

On Malyan Homepage it is a .exe file to update via Windows CMD Shell