Print stop after serial connection lost due to unknown error

What is the problem?

I have an Anycubic Kobra NEO, that I have been using over more than 6 months with OctoPrint with close to no major issues until now. I tried several times to print a somewhat large print with only 1cm or so left from the edges of the build plate. The print starts normally and randomly stops in one place keeping the extruder and build plate ON at the set temperature for the printing but the head does not move, which is a HUGE fire hazard and there fore I can't rely on that printer printing with OctoPrint through the night, and printing large objects is impossible that way.
The print stops very randomly, one time it can print 6 layers with no issues and then freeze. Other times freezes half way through the first layer of the same print. I was stubborn and kept trying to print the object several times.
The printer is connected through a UPS to the main grid and on that main power line the only other thing is a refrigerator, but it is not connected through the UPS. And this is months of printing like that with no issues.
The error that OctoPrint gives me is:


2023-08-18 19:23:57,742 - Send: M27
2023-08-18 19:23:57,747 - Recv: Not SD printing
2023-08-18 19:23:57,747 - Recv: ok
2023-08-18 19:23:58,356 - Recv:  T:82.46 /0.00 (2775.13) B:51.07 /0.00 (3593.13) @:0 B@:0
2023-08-18 19:23:58,544 - Unexpected error while reading serial port, please consult octoprint.log for details: SerialException: 'device reports readiness to read but returned no data (device disconnected or multiple access on port?)' @
2023-08-18 19:23:58,544 - Please see for possible reasons of this.
2023-08-18 19:23:58,550 - Changing monitoring state from "Operational" to "Offline after error"
2023-08-18 19:23:58,553 - Connection closed, closing down monitor

Apparently the OctoPrint log has been erased since there were a couple of days since I last had the chance to fiddle with the printer So I can't provide the log but in general it said " error occurred sending M112 disconnect due to error..."

What did you already try to solve it?

I updated OctoPrint from 1.9.0 to 1.9.2
I updated the firmware on the printer itself to version 1.3.3 from 1.2.8
I tried running the print in safe mode
Updated the slicer Ultimaker Cura from 5.2.2 to 5.4.0 and sliced the model again

Have you tried running in safe mode?

Yes, the same problem occurred

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (104.6 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Anycubic Kobra NEO firmware 1.3.3 connected through a UPS
Laptop Running Kubuntu 23.04 running OctoPrint 1.9.2 on the same UPS

I tried simulating a print without wasting more filament using the plugin DryRun. And the printer just lost connection again.

2023-08-21 17:44:54,116 - octoprint.server.util.sockjs - INFO - User kamen logged in on the socket from client
2023-08-21 17:44:54,397 - octoprint.plugins.tracking - INFO - Sent tracking event webui_load, payload: {'browser_name': 'Edge', 'browser_version': '115.0.1901.203', 'os_name': 'Windows', 'os_version': '10'}
2023-08-21 17:46:18,001 - octoprint.server.util.sockjs - INFO - Client connection closed:
2023-08-21 17:52:51,750 - octoprint.util.comm - ERROR - Unexpected error while reading from serial port
Traceback (most recent call last):
  File "/home/kamen/OctoPrint/venv/lib/python3.11/site-packages/octoprint/util/", line 4081, in _readline
    ret = self._serial.readline()
  File "/home/kamen/OctoPrint/venv/lib/python3.11/site-packages/octoprint/util/", line 6832, in readline
    c =
  File "/home/kamen/OctoPrint/venv/lib/python3.11/site-packages/serial/", line 595, in read
    raise SerialException(
serial.serialutil.SerialException: device reports readiness to read but returned no data (device disconnected or multiple access on port?)
2023-08-21 17:52:51,772 - octoprint.util.comm - ERROR - Please see for possible reasons of this.
2023-08-21 17:52:51,776 - octoprint.util.comm - INFO - Changing monitoring state from "Printing" to "Offline after error"

octoprint.log (33.5 KB)
serial.log (311.0 KB)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.