Print stops midway, happened twice in a row


#1

I am running OctoPi 1.3.8 on an RPi ZeroW, with a Pi camera connected to a Prusa i3Mk2s. It has been working great for dozens of prints, then after I flashed the firmware to the latest version 3.1.0, I get two prints in a row that stop midway, for no apparent reason. I tried the same gcode both times, but it stopped at different places in the print each time. The Pi remains on a running (I can SSH into it and restart OctoPrint). The power supply and USB cable have been reliable, but I can't tell why it stopped.

I tried disabling a few plugins between prints, but it still failed the second time. If I print now, direct from the SD card, it appears to work just fine.

Any ideas?

Uploading log files for each print
OctoPrint Freeze logs.zip (434.6 KB)


#2

You want do downgrade that firmware back to what it was before, 3.1.0 has severe issues with serial communication (and for some reason Prusa has still not released a fixed version or at least removed the 3.1.0 download even though this problem has been known for months :unamused:):


#3

Is the Raspi Zero soldered on?

I only ask because it might be using the cheap UART rather than the good one.


#4

The Pi zero is not suitable for running octoprint and a webcam together. It doesn't have the processing power to keep up with both. It's mentioned in the github notes and a few other places.


#5

The Prusa's design is specifically made so that a Pi Zero can be soldered right onto the board, which of course encourages their users to do so.


#6

My PiZeroW has been working beautifully running OctoPi for almost a year, so I don't think that the board is the problem.


#7

Thanks for the tip. I downgraded back to 3.0.11 and it works fine again.

My concern now is that I ordered the Prusa Mk2.5 upgrade, which requires firmware 3.2.1. Are you aware if they have fixed these serial communication issues in the 3.2.1 version (vs the 3.1.x versions which appear to still have the issue)?

Rob


#8

AFAIK they fixed the serial issues in 3.1.1rc4, so 3.2.1 should be fine. At least I'm only aware of issues with the MK2/2s machines on 3.1.x.

I've also repeatedly asked them to please make it more transparent to their users that 3.1.0 is ill suited for use with host software ever since these issues first arose end of last year, since people keep running into this (and often blaming me instead of the broken firmware) but sadly so far no action :confused: