Print worse through octo

What is the problem?

Prints sent through octopi turn out worse than using the same gcode and printing via USB

What did you already try to solve it?

reset printer profile in cura and octoprint

Have you tried running in safe mode?

No, I'll try that if there are no other ideas

Did running in safe mode solve the problem?

Systeminfo Bundle (80.4 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

USB is on left, Octoprint is on right

And how do you connect OctoPrint to the printer?

through USB

So isn't that a contradiction when you say a print form OctoPrint via USB is worse than a print (from what ever) via USB?

Wow, ok, let me clarify for the pedantics. When I print through octo print which is connected to my printer via usb, I get worse quality prints than when I print directly from Cura slicer on my computer which is connected to the printer via usb. I physically unplug the USB from the octopi machine and plug it into my laptop.

Is that better? Can I get some actual advice now?

Also, I just spent an hour or so failing print jobs though the octoprint because it looks like after doing the bltouch ABL process, it raises the z offset somehow. Connecting back to the computer and printing (not using any gcode to change z offset) and the print is finally sticking to the bed. I wonder if I should just wipe out the octopi and reload from scratch.

You did not mention in your OP that you print from Cura when not printing from OctoPrint.


First pleas do it:

This is always the first idea.

You also may check your plugins:

2022-08-23 17:04:02,767 - octoprint.plugin.core - WARNING - Plugin USBControl (1.0.8) is not compatible to Python 3.7.3 (compatibility string: >=2.7,<3).
2022-08-23 17:05:52,733 - octoprint.plugins.obico - ERROR - Attempt 1 - backing off 0.209088 seconds: Janus WS connection closed!
2022-08-23 17:05:52,750 - octoprint.plugins.obico - ERROR - STDERR:
2022-08-23 17:05:52,826 - octoprint.plugins.obico - ERROR - Attempt 1 - backing off 0.142588 seconds: Janus quit! This should not happen. Exit code: 143
2022-08-23 17:05:52,943 - octoprint.plugins.obico - WARNING - Reconnecting to Janus WS.
2022-08-23 17:05:52,949 - octoprint.plugins.obico - WARNING - Server WS ERROR: [Errno 111] Connection refused
2022-08-23 17:05:52,950 - octoprint.plugins.obico - WARNING - WS Closed - None - None
2022-08-23 17:05:52,950 - octoprint.plugins.obico - ERROR - Attempt 2 - backing off 0.581411 seconds: Janus WS connection closed!
2022-08-23 17:05:54,345 - octoprint.plugins.obico - WARNING - Reconnecting to Janus WS.
2022-08-23 17:05:54,359 - octoprint.server.api.system - WARNING - Command for core:restart failed with return code -15:
2022-08-23 17:05:54,412 - octoprint.plugins.obico - WARNING - Server WS ERROR: [Errno 111] Connection refused
2022-08-23 17:05:54,428 - octoprint.plugins.obico - WARNING - WS Closed - None - None
2022-08-23 17:05:54,429 - octoprint.plugins.obico - ERROR - Attempt 3 - backing off 1.082954 seconds: Janus WS connection closed!
1 Like

Wish I had an answer for you. I've been 3D Printing for about 2 yrs now, and I have had the exact same issue since day 1. I have no idea why. I've tried different brand cables, different baud rates, and TONS of other stuff. I've finally got it to the point the octopi prints are "decent", but still obviously not as good as using a usb stick. Besides, I really don't like starting a print when not there to actually watch it start. It seems I usually have to babystep it a little bit anyway.

I've done some further testing and here's what I found.

First, I went back to basic. I manually leveled the bed, then sliced a model with cura 4 with all settings reset to defaults and bltouch commands removed. I copied the gcode to sdcard and printed from that. This produced a very good print. It used a raft for adhesion, which I don't like, but forgot to change it so I continued using raft for the rest of my tests.

Second test, I re-added the bltouch code and re-did the z-offset settings following the instructions from Longer. Everything else was the same, same model, used sdcard, etc. The raft on this was not as firm, but it worked and the print was again, pretty good.

Next, I connected the USB to my computer and printed direct from cura. I adjusted the z-offset a bit trying to get better adhesion, but that still wasn't perfect. This time, I started to see some small bumps here and there in the print, overall, it was ok, but not as good as the first two.

I then added the octopi. I had wiped it and reinstalled and set up from scratch. connected the raspberry pi to the printer via usb and sent the print. Z-offset still not correct and the print actually detached with about 5 layers remaining, Not a tragedy in this case, but still something (I blame that on z-offset settings which I have worked on since then and have much better adhesion now). This print had blobs and bumps all over it. I noticed the printhead would randomly stop for a few seconds, then continue on, producing the little blobs everywhere.

I went on to print a few more things while dialing in the z-offset, and always when I print through the pi, I get the worst quality.

SO, what is octo doing that would cause the printer to randomly pause?

Damned if I know. If I knew the answer I would (1) have fixed mine already, and (2) given my solution to you. LOL. Hopefully somebody that knows about this crap will tell us.

I have the pausing issue too. Ender 3 V2, Jyers firmware, Pi Zero 2 (also tried Pi4). Worst one was when it just crashed with the nozzle sitting near the bed in a pile of PLA goo. The temperature didn't turn off so it was just hearing itself up. It's borderline dangerous so I just print from SD now and use OctoPrint as a monitoring tool with the camera only.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.