Printer can't hold temperature out of nowhere

What is the problem?

I wanted to print a new Fan Duct. It went good for like 2 hours. But then suddenly the printer had a problem with it's temperature. Normally it holds the temp pretty good, in this print on 205°C ±0.6°C.
But suddenly it was going up to 210.3°C and then down to 199.6°C and then I got a Printer halted. kill(). I mean, I am happy that this safety feature exists and that octoprint is shutting off the outlet immediatly, but I really don't know why the temp was suddenly going crazy.

What did you already try to solve it?

Nothing yet. I only checked of the Silicon Sock was sitting right (it was)

Have you tried running in safe mode?


Systeminfo Bundle (225.1 KB)

Additional information about your setup

OctoPrint version: 1.7.2 OctoPi version: Pi 4 Model B 4GB Printer: Ender 3 V2 Firmware: Ender3 V2-4.2.2 Marlin-2.0.1-BL-Touch – V1.1.1 Browser: Google Chrome Operating System: Win11 Slicer: Cura 4.12.1

Hello @Gh0stShell !

Is this issue repeatable?

Also please:

You also may check the wiring of the thermistor and the heater cartridge.

This was the second time with this exact model. I tried to print this a few days ago and I got this error. So I made a quick check and the connection to the thermistor looked fine. After that I printed 6 or 7 other things and I thought it's fine so I tried this print again. And now I got the same error. I am not really sure where the problem is, it doesn't sound like a PID Problem. I'll check the thermistor again. I really hoped I could print the new fanduct before I need to take the old one apart. :frowning:

Edit: I'll also try an Octoprint Update, I saw that I was still on 1.7.2 and not on 1.7.3

I can say this won't have an impact towards fixing it - there's nearly no changes between the two.

Did you slice it again for the second print or did you use the gcode of the first one?
Maybe something went wrong the first time

Maybe we should have a look onto the gcode file.

1 Like

Sorry, that I didn't answer.
@PrintedWeezl I used the same gcode both times. I sliced it again and this time I lowered the temperature by 5°C so I print on 200°C instead of 205°C. I am not sure if this was the problem. It's still printing at the moment.

@Ewald_Ikemann Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.
Those are the gcode files. I put a "205C" and "200C" at the end of the filenames. The 205C file is the one I printed first, two times. The 200C version is the one I am printing at the moment.

I am pretty glad that this community really has the mindset to help eachother. :smiley: (Not like some other communities I know)

The gcode files look fine.
Already tried safe mode?

Oh no, I forgot to activate it. But I am watching the print all the time at the moment and I saw something interesting. When it prints top layers, the part cooling fan turns off (I think for a smoother surface), but everytime when it does this the hotend temp has this bumps, also when the fan turns back on you see a drop down in temp. So I think it could be that the part cooling partially cools the hotend, too.

Could be that I never had this with this fan duct, because I never printed something which is that "complex"

From the picture it does look like the part cooling ducts are pointed at the nozzle. You could try lowering the fan speed from 100% to maybe 90% or 80%.

Hopefully, your new duct will direct the air better.

1 Like

So, just a quick conclusion to end this thread.

As I said before I started the print on 200C instead of 205C and it printed all the way through. The new fan duct is better in terms of the direction of the air. But it looks like that I should do PID Autotune anyways. Because, with the newer fan duct, the the cooling of the hotend fan is "better".

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.