Printer Disconnecting at the end of bed leveling

What is the problem?

Printer disconnects and octoprint says it stopped responding at the end of bed leveling.

What did you already try to solve it?

ive already replaced or tried new cables (all high quality shielded etc cables with ferrites on both ends)
Checked voltage and even swapped power supplies just in case.

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

No

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint-systeminfo-20240204153626.zip (107.9 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
Anet A8
Raspberry Pi 4 b octopi 0.17.0
Octoprint 1.9.3
Any help would be appreciated. thanks in advance

Traceback (most recent call last):
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/util/comm.py", line 4081, in _readline
    ret = self._serial.readline()
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/util/comm.py", line 6832, in readline
    c = self.read(1)
  File "/home/pi/oprint/lib/python3.7/site-packages/serial/serialposix.py", line 596, in read
    'device reports readiness to read but returned no data '
serial.serialutil.SerialException: device reports readiness to read but returned no data (device disconnected or multiple access on port?)
2024-02-04 15:10:45,730 - octoprint.util.comm - ERROR - Please see https://faq.octoprint.org/serialerror for possible reasons of this.
2024-02-04 15:10:45,737 - octoprint.util.comm - INFO - Changing monitoring state from "Operational" to "Offline after error"

You may want to look in the URL listed in the error above on the second to the last line.

Does the issue repeatedly happen at the end of be levelling? Or is it just unfortunate timing that you got a communication issue here?

every time without fail so far as it finishes probing. same point every time. it used to be intermittent but after a power outage i reset the printer and now every time witrh seemingly every file i try to print.
i also removed the camera to see if the usb power is enough. im using a canakit power supply for the pi4. this particular one worked for about 3 years without any issue. (i had low voltage on a previous setup on a pi3, which is why i upgraded to the pi 4 and canakit power supply.)
EDIT: ive unplugged everything from my pi except the printer itself and no change.