Printer doesn't reconnect after switching off and on (was working before...)

Hi,

I have a Creality Ender 3 that was hooked up to a Raspberry 4 / OctoPi.
All was working great, but I decided to re-image my Raspberry with the OctoPi containing the "new camera stack".

To do so:

  1. I backed up my Octoprint installation
  2. Re-imaged the Raspberry PI with the "Octopi (new camera stack)" distro
  3. Finally restored Octoprint config from the saved archive file in step 1.

So far so good. I retrieved all my config. Printer is connecting to Octoprint...

BUT, before re-imaging my Raspberry, when I log to Octoprint UI while my printer was OFF, then switching ON my printer, I was able to see my printer automatically connect to Octoprint.

Now, I have to click the "Connect" button for the printer to reconnect to Octoprint after I switching it ON.

Any idea of how I can restore the former behavior (a.k.a printer auto-connect on switch ON)?

Thanks for helping.

octoprint-systeminfo-20240209095627.zip (635.6 KB)

PS: I have 2 Octoprint instances. One on my Ender 3, and one on an Artillery SideWinder X2.
I did the same on both instances (re-imaging with "Octopi (new camera stack)" distro).
Got the very same re-connection issue on Octoprint instances.

Before you click connect, check "auto connect on server startup" and "save connection settings" then click connect

1 Like

Hi @5ft24,

Thanks for your help.
Unfortunately, checking both "auto connect on server startup" and "save connection settings" checkboxes didn't fix my issue.

While connected to Octoprint UI, if I power cycle my printer (shut it down, then power it up), I can see:

  1. the connection been lost with an error (when shutting down) :white_check_mark:
  2. then the serial port being added back to the list (when I power up) :white_check_mark:
  3. but the printer doesn't reconnect automatically. I have to click on the "Connect" button... :x:

Regards,
iGoX

OctoPrint doesn't automatically reconnect to the printer like that - it's not something that is implemented.

I think the Portlister plugin might have done this - but not sure. Also, plugins like PSU Control can auto connect the printer if they power on the printer.

Iirc it didn't.

Hi,

Quite interesting comment.
Until not long ago, I had both "PSU Control" and "PSU Control - Meross" plugins activated.
But I deactivated them since I had trouble with the "PSU Control - Meross" one.
Maybe it is related...

Ragards,
iGoX

yeah several printer power control plugins have that feature

They connect to the printer after powering it on

I have a KP3S and a KP5L each connected to their own RPi4.
Neither would reliably Auto-connect.
In the Connection dialog I entered these settings:

  • Serial Port: /dev/ttyUSB0
  • Baudrate: 115200
  • Printer Profile: [KP3S|KP5L]

I then checked 'Save connection settings' before I clicked on Connect.
After that 'Auto-connect on server startup' worked reliably.