Printer dosen't respond to any commands

Hello, my 3D printer won't respond to any Commands, but I can connect to the printer.
I already tried to install octoprint multiple times but always the same result. After about a minute octoprint gets a timeout and I'm getting this error message: No response from printer after 3 consecutive communication timeouts, considering it dead. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves.
Changing monitoring state from "Operational" to "Offline (Error: Too many consecutive timeouts, printer still connected and alive?
My Prusa i3 mk3 is on the newest firmware as well as Octoprint.
Thanks for your help!

Can you describe your setup?

Model of Raspberry
How you're connecting this to your Prusa (USB cable?)

1 Like

Thanks for your reply! I‘m using a rasperry pi 3 connected via usb

Great. (A lot of people attempt to solder a Pi Zero to their Prusa.)

The USB cable needs to be as short as possible, include an internal metallic shielding or include a ferrite core around it. The ends should fit snuggly.

You might want to manually set the baudrate if you know what it's supposed to be for your printer. If you have multiple USB things plugged into the Pi, you might want to just plug in the printer first and try that.

Also make sure that you haven't set your Prusa to the GPIO based serial in the Settings, otherwise USB won't work as far as I understand.

If that doesn't help - log files please.

1 Like