Printer gets to temp, then nothing

What is the problem?

I send a print job and the printer starts heating up. It reaches temp, then just sits there. Never starts printing

What did you already try to solve it?

Resliced model, restarted printer, restarted octopi, printed direct over USB to laptop with cura (This worked, which is why I believe it to be octoprint issue)

Have you tried running in safe mode?

Yes, no change

Did running in safe mode solve the problem?


Systeminfo Bundle

Additional information about your setup

env.plugins.pi_support.model : Raspberry Pi 3 Model B Rev 1.2
env.plugins.pi_support.octopi_version : 0.18.0
env.plugins.pi_support.octopiuptodate_build : 0.18.0-1.8.2-20220816135025
env.python.pip : 20.3.3
env.python.version : 3.7.3
octoprint.version : 1.8.6
printer.firmware : Marlin 2.1 (Jan 8 2023 21:04:13)

Sliced with cura (Tried 5.2.1 and xmas build)
Printer is Longer Lk5 Pro

Up until Monday, I was printing just fine, then suddenly, when I send a print. The bed heats, the hot-end heats, then nothing. I can home and move the bed and print head, I can run a bed level, all mechanical function is working properly. It's like the start command just isn't going through.

I'd like to continue using octoprint, but right now the only way to print is to connect directly to the printer with USB from my laptop and print from cura.

I'd like to see another bundle with the serial.log enabled and a screenshot of the OctoPrint Temperature tab at the point where you believe it is "stuck".

I guessing that its a PID issue which should be corrected by tuning, M303 and M301 (save it with M500).

The ambient temperature might be playing a part in the erratic behavior.

Running a print that was one at a time, first item printed ( I didn't change anything, it just worked that time) but in between objects, it's stopped again. You can see in the temp graph about 15 minutes ago when it went up to my 1st layer temp of 215

serial.log (16.0 KB)

I think a PID tune would help. You can write down the current values, do the tune, and try the new values. Current values are printed with a M301 with no parameters or an M503.

Notice how your temperature graph oscillates around the target temperature. Below is a temperature graph from my LulzBot TAZ 6. A little ringing when it reaches the target temperature but then it is pretty much a flat line. Your nozzle temperature should look like your bed temperature.


I had been relying on auto pid tuning and it didn't flatten the line, so I entered the numbers manually and it's looking better. I just sent a print and it did start, so this is looking promising. Thank you, I had no idea that the temperature needed to stabilize better before the print started.

Glad to hear its working better!

What do you mean by "auto pid tuning"? If you mean the U parameter on the M303, I have never had much luck with that. I copy the output of the M303 into an M301 command and then do a M500 afterwards. Double check with M503, power cycle the printer, and check with M503 again.

I have multiple printer profiles in my slicer, one for each tool head. I have added the M301 to my start gcode.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.