Printer halted. kill() called!

What is the problem?

The printer starts the print, then stops with this error message. I have tried several times, same result. In the logs, it looks like this (a full system export is also attached).

In some of the cases the printer did print some of the first layer before the error occured, but the "busy interval" was still there right before the crash.

I started with Octaprint because I wanted to move the printer to a place where a USB-cable isn't feasable. Prior to doing so, I tested it and everything seemed to work just fine. The place I moved it to has a bit unstable wifi, but does Octa need wifi once the print is recieved and started?! It is also a bit cold, about 13C during the last two prints. The temperature seems to be holding just fine though.

Here's what the log says just prior to the faliure:

2022-10-13 19:44:50,831 - octoprint.util.comm - INFO - Changing monitoring state from "Starting" to "Printing"
2022-10-13 19:44:51,161 - octoprint.plugins.tracking - INFO - Sent tracking event print_started, payload: {'origin': 'local', 'file': 'f215e6d8f759ff4a2ec5662fb801839566c12775'}
2022-10-13 19:44:52,876 - octoprint.util.comm - INFO - Printer seems to support the busy protocol, will adjust timeouts and set busy interval accordingly
2022-10-13 19:50:35,562 - octoprint.util.comm - INFO - Telling the printer to set the busy interval to our "communicationBusy" timeout - 1s = 2s
2022-10-13 19:55:06,814 - octoprint.util.comm - WARNING - Received an error from the printer's firmware: Printer halted. kill() called!
| Last lines in terminal:

What did you already try to solve it?

1: tried again a few times
2:Looked through all the mentions of the error message in this forum and on google, but none of them looks quite like it.

Have you tried running in safe mode?

Yes I have.

Did running in safe mode solve the problem?

It did not help

Systeminfo Bundle

(upload:// (1.8 MB)


Additional information about your setup

OctoPrint version, OctoPi version: Latest on a R.Pi 4, printer: Ender 3, firmware: Marlin for BL touch, (also have BL touch installed)
as much data as possible

Hello @Martin_Vinter !

Somehow the upload of the systeminfo bundle did not work.

  • Download the systeminfo bundle to your PC
  • Upload the systeminfo bundle from your PC to your next post by using:


Hi @Ewald_Ikemann

Thank you for responding. I have tried again. (1.8 MB)

First, your Pi suffers from an undervoltage issue and is throttled:

|      throttle_state: '0x50005'

And please, do not restart the Pi by power cycling it. This can lead to a corrupted file structure on the Pi's SD card.

To your issue:

The last lines in the terminal show up some temperature reports.
From this, it seem that the kill is not causes by a thermal runaway.

For this is a Creality printer, you also may try with/without a SD card in the printers SD
card slot.

Does this happen always happen at the same point when you want to print?
You may share the zipped gcode file in your next post.

Wow, I am impressed by the thoroughness you put into helping a stranger. Thank you. A lot!

I will give the things you mention a try/test tomorrow and see if I can rule some of them out. If that doesn't work, I'd be happy to share the gcode, but let's not have you spend time on that just yet.

I most trials, it happened just as the printer started. In one, it happened during the first layer of a somewhat big-ish print, so maybe 3 or 5 minutes into the print.

Hi again,

So I measured the voltage on the pi and the 5v to gnd pins have a voltage of 5.2 between them, which I believe is the recommended voltage for a pi. The supply says it can deliver 3Amps and the red light is on without any blinking. Also, the 500005 is only there during the testprints I made prior to moving the printer. While it was inside, I was using a phone-charger (which worked just fine, but may have produced the under-voltage message)

The error started occuring when I moved the printer to the garage. There is a different wifi-network out there. Could this be a network connectivity issue? If so, I am contemplating buying a Mesh network, but those are expensive. I'd like to be certain that it'll fix the issue...

No, the issue is nothing to do with the network connection. The kill message is generated by the printer firmware, which doesn't connect to be internet. Often it is caused when the printer is shutting down due to an error or safety issue.

To clarify (as I read your earlier post) once the file is uploaded to OctoPrint there's no need for a network connection for it to continue printing - just the USB connection to the printer.

If you were to enable the serial.log, reproduce the issue and then upload that file here so we can look, it might give some more clues as to what is going wrong with it. In the log it is just reporting as 'busy', with no clue as to the last command that was sent. Sometimes for example if homing fails, then this error can be triggered.

I think @Ewald_Ikemann already mentioned it, but Creality printers are known for random bugs like this depending on if the SD card is in or not. That's only with the stock firmware though, flashing your own build of Marlin should be fine.

I brought the printer in to play around it some more, connect it via USB, use a different Octo-installation and so on. Then I noticed a snag causing the Z-axis not to move freely. I must have been introduced for some reason when I moved the printer and that is why I thought it had to do with Octo, network and so on because that is also when I started printing from it. A little lube and a few adjustments here and there and it woks fine again, it seems.

1 Like

Oh, one more thing, I suppose the most important one: thanks a truckload for helping out @Ewald_Ikemann and @Charlie_Powell !

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.