Printer homing issue ? Slams into the side at just the start of print

What is the problem?

My print head slams into the side at the start of a "Smart Compatability" trigger timelapse. It does this at the very start but has no problem afterward. For all of the other layers, the print head moves fine and doesn't slam into the side.
I will attach a video to show you guys what is going on.

What did you already try to solve it?


Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Any thoughts @FormerLurker ?

Does it have to do with something with the start code? My print bed size settings?
Because the 2nd layer of the print is offset a few mm from that 1st base layer and the print continues on the 2nd layer's position.

The serial.log (please enable it first) will have crucial information.

1 Like

Thanks for the response!!

Funny thing is that when I set the stabilization to the Front Left, it doesn't seem to slam into the side.

serial.log (148 Bytes) octoprint.log (71.7 KB)

2021-02-01 18:40:59,930 - serial.log is currently not enabled, you can enable it via Settings > Serial Connection > Log communication to serial.log

Please enable serial.log first...

Ahhh, my mistake.

serial(1).log (88.6 KB)

Is it hitting the X axis endxtop? Do you hear it 'grinding' during the first move? If so, I'd say your bed size needs to be adjusted a bit. Perhaps try XMIN = 5 or 10?

You can easily test this via gcode. Do a G28 to home XY and Z, then raise z (say G0 Z10), now move to the XMIN coordinate you have entered into Octolapse (maybe G0 X0 or whatever your profile says). See if your x axis skips.

Also, I wanted to say, I'm not familiar with the kind of printer you have (at least not by site), so I'm not sure where you are stabilizing to (back right? front left?), or what your build volume is, or what absolute coordinates your printer is configured to use. Your octolapse printer profile would be helpful (you can easily download this from the Octolapse settings page) so we can see what your current settings are.

I posted a video at the top of the tread. So you can hear and see it.
settings.log (58.6 KB)

I'm using a ROBO 3D R1, I think you were going to create a profile for it once we get all of the bugs worked out of it :slight_smile:

Perhaps a sensor issue?, those little clicker sensors to tell print head it is at the end of the bed. Maybe I need to tighten some screws. (forgive my lack of terminology)

LOL! Yeah, you're right. Looks like there are still a few bugs :slight_smile: