Printer is connected, State is Operational, successfully uploaded STL file, but Print, Pause, and Cancel buttons are grayed out and unavailable. I'm not able to print


#1

My issue is that after I successfully connect to my printer (Robo 3D R1+) and successfully upload an stl file that I would like to print, I see that the Print, Pause, and Cancel buttons are grayed out and unavailable. Therefore, I'm not able to print.

So far, I've tried uploading another stl file to see if it enables the Print, Pause, and Cancel buttons without any luck. I tried disconnecting and reconnecting to my printer. I've even backed out of the Octoprint server entirely, rebooted pi, restarted Octopi server and I'm still unable to see the Print, Pause, and Cancel buttons become available for use. I've also switched from using Google Chrome to FireFox, and the buttons are still unavailable after I try uploading two different STL files. Is anyone familiar with this issue and how to resolve it?

I'm running on OctoPrint v.1.3.8, Octopi v.1.4, Robo 3D R1+


#2

Normally, an .stl file is sliced on your main computer and then the .gcode output is uploaded to OctoPrint for printing.

When you upload an .stl file, you should get a popup window for slicing and you need to select a slicing engine and a profile. If you want to go this route, let us know. Be aware, the steps are complicated.

A quick glance at Robo 3D R1+ shows they recommend MatterControl for this printer. They also have a flavor of Cura which isn't recommended for this printer, but appears to have the R1 listed as one of its builtin printer configurations. Ultimaker's Cura also lists the R1 as one of its "Other" printers.

Either of these two programs should have the ability to save the sliced output (GCode) to a folder which can then be uploaded to OctoPrint.

When you upload a .gcode file to OctoPrint, the Print button should become available and when you start the print, the Pause and Cancel buttons should become available.


#3

@b-morgan is right on the money, here.

I think I'd download Cura, slice the STL in there for the Robo and then upload that GCODE file to the printer via OctoPrint's interface. You'd then select that GCODE file and the interface should be happy with that.


#4

b-morgan and outsourcedguru, slicing the file and saving as gcode on my local machine then uploading in octoprint web ui worked. thank you (:


#5

Please mark this as solved then using the :marksolved: icon.