Printer makes startup noise when connecting, but no connection happens

I'm running Ubuntu 20.04 with OctoPrint on a Proxmox VM and the USB port is passed through to the VM. I can see the port in the port selection dropdown.

Printer is CR-10S Pro and when I try to connect, the printer makes a startup sound, then fails to connect with the

State: **Offline after error**
No more candidates to test, and no working port/baudrate combination detected.


I've followed tutorials to a tee and I'm not getting the same result. Where should I start for troubleshooting?

When you opened this topic, there were some prompts to help you provide as much information as possible to help others help you.

The most important parts that have been missed:

Have you tried running in safe mode

Did running in safe mode fix the problem?

Systeminfo bundle upload

Additional information about your setup
OctoPrint version, OS and version, printer model & firmware version etc.

Safe Mode: Yes.
Safe Mode Fixed? No.
Systeminfo bundle: Attached.

Running on Ubuntu 20.04 in a VM in Proxmox with the USB port assigned to the VM as a passthrough port.

The printer keeps cycling the power on sound every once in a while and I can't figure out what's causing it, nor why OctoPrint fails to see it.

When I was running OctoPrint on my other Ubuntu 20.04 server (which was running as the sole OS on the host with no virtual environment) it worked. So I know that the printer is compatible with it. Just can't make sense of the failed connection.

I have two USB cables here. Both have the ferrules on the ends of them, and if I'm not mistaken, that wouldn't be the case if the cable was only 2 wire / power only, so I'm fairly sure the cables I have are appropriate. Unfortunately I don't have any other devices in the house that use the same USB connector that the CR10S-Pro uses. (21.5 KB)

So, by my reading, the printer works, the cable works, and it works with OctoPrint. OctoPrint sees a serial port, but it gets no reply from it. I would say that by process of elimination, that there is something wrong with the configuration in the VM to pass through the USB device, because everything else (sounds like) it has been ruled out.

2022-06-04 19:16:00,503 - Trying port /dev/ttyUSB0, baudrate 115200
2022-06-04 19:16:00,504 - Connecting to port /dev/ttyUSB0, baudrate 115200
2022-06-04 19:16:00,566 - Handshake attempt #1 with timeout 5.0s
2022-06-04 19:16:00,567 - Connected to: Serial<id=0x7f187019b880, open=True>(port='/dev/ttyUSB0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=5.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
2022-06-04 19:16:00,569 - Send: N0 M110 N0*125
2022-06-04 19:16:05,577 - Handshake attempt #2 with timeout 5.0s
2022-06-04 19:16:05,607 - Send: N0 M110 N0*125
2022-06-04 19:16:10,594 - Handshake attempt #3 with timeout 5.0s
2022-06-04 19:16:10,598 - Send: N0 M110 N0*125
2022-06-04 19:16:15,604 - Trying port /dev/ttyUSB0, baudrate 250000
2022-06-04 19:16:15,608 - Handshake attempt #1 with timeout 5.0s
2022-06-04 19:16:15,610 - Send: N0 M110 N0*125
2022-06-04 19:16:20,617 - Handshake attempt #2 with timeout 5.0s
2022-06-04 19:16:20,621 - Send: N0 M110 N0*125
2022-06-04 19:16:25,629 - Handshake attempt #3 with timeout 5.0s
2022-06-04 19:16:25,633 - Send: N0 M110 N0*125

Also, it is trying to autodetect with 66 different candidates - I would suggest manually selecting the serial port, you have /dev/ttyS[0-31] also in the mix which will just slow you down.

I have no knowledge of Promox and the configuration there, but I would suggest either checking that, or maybe posting whatever configuration is used there so that if there is someone who does know how it works they may be able to see what's wrong.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.