Printer not turning off Extruder and bed heating after printing with latest Octoprint

What is the problem?

4 times I have printed some objects and the heated bed and Extruder stay stuck at operating temp after the print has finished. I have had to manually intervene to turn them off via Octoprint. (15.4 KB)

What did you already try to solve it?

Dont know what to do

Have you tried running in safe mode?

yes - it still does it.

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Link to image i used V1Pi v0.18.0 - Software / Firmware / General - V1 Engineering Forum


Can you share the gcode file you are printing? - You may zip it to get it smaller.

DeWalt_battery_holder 102% (365.4 KB)
Hopefully i have successfully attached it.

As it looks, at the end of the file, there are no commands to turn the heaters off:

G1 X153.097 Y203.688 E73.63251
; INIT stop printing object DeWalt_battery_holder.stl id:0 copy 0
G92 E0
G1 E-0.20000 F2100
; stop printing object DeWalt_battery_holder.stl id:0 copy 0
M486 S-1
; Filament-specific end gcode 
;END gcode for filament
G28 X0  ; home X axis
M84     ; disable motors

In the end gcode section of your slicer ther should appear

M104 S0
M140 S0

Ok thanks a lot for the help. I am puzzled by what has changed to make it behave like this, however it is a straight forward fix. Thanks again - much appreciated.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.