Printer Reboots when Octoprint Connects

#1

What is the problem?
When initiate a connection to octoprint via Chrome on two different computers so far it causes the actual printer to reboot.

Recent change was that I switched to TH3D Firmware

What did you already try to solve it?

  1. Tried to see if it would happen while the printer was printing. - It did
  2. Tried to see if it would happen when the printers was on but not printing - it did
  3. Rebooted Pi & Computer and tried above again with the same results.
  4. Selected disconnect and then reconnect and it still rebooted the printer.
  5. The Octoprint session and Pi never seem to throw a direct error or reboot when this happens.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

Tevo Tornado G1 - no major mods
TH3D V1.R2.10d

octoprint.log (48.1 KB)

#2

octoprint.log

octoprint.log (48.1 KB)

#3

There's a problem when you connect to the printers serial port. Look around here for steps on how to solve it. (On mobile, not withwhile to paste links).

Secondly, having a reference to Docker is weird:

octoprint.plugins.webcamstreamer - ERROR - Docker not responding: ('Connection aborted.', error(2, 'No such file or directory'))

#4

Thanks for the reply. I will check that out shortly. Have a 24 hour print going so now not able to log into octo to verify. LOL

Yeah that webcamstreamer isn't configured, so probably just need to disable it until i get around to actually using it.