Printer stopping mid print

What is the problem?

When i'm printing something curvy via Octoprint, the printer is lagging randomly and leaves blobs at this positions, where it pauses. After a time it stops printing completely and stays at one position. I can't operate the printer anymore with the knob. You can see the Octoprint log down below.

I have to shut down the printer and turn it on again but the print cannot be continued anymore.

Printer: Creality Ender 3 with FYSETC Cheetah v1.2b 32 bit board (TMC2208 Stepper driver with a current of 580 mA on x,y and z and 650 on Extruder)
Raspberry Pi 3 Model B Rev 1.2
octopi_version: 0.16.0

What did you already try to solve it?

I tried different USB Cables, no change. Changed baud rate to 250000, BLOCK_BUFFER_SIZE to 64, changed the Net density in Cura to 0.5......
i have no clue what i could do anymore
I printed via SD Card and have no issues then.

Logs (syslog, dmesg, ... no logs, no support)

octoprint (1).log (10.8 KB)

Additional information about your network (Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ...)

Hello @Goleon!

The 32bit board should be fast enough.
Please also share the serial.log.
If you can't operate the printer directly any more, there could ba a firmware issue.

the serial log was not enabled, i'm sorry...
i also thought about the Firmware (Marlin 2.0.x bugfix) but why does it only happen when i'm printing via Octoprint and not when printing via SD?

That is to find out.
You may switch to Marlin 2.0 full release

1 Like

hm... very sad. never heard, that someone had problems because of the 2.0.x bugfix version. But maybe i should give it a try. Tomorrow i can try this out. Will tell you then, if it works.
Thank you so far.

Okay, i reinstalled Marlin, but the 2.0.3 Version, changed what i had to change for my mainboard and turned some things on like S_CURVE_ACCELERATION, ADAPTIVE_STEP_SMOOTHING. Just did one print via Octoprint where i had the problems. The lagging with leaving blobs is still an issue and it also freezed entirely. Same issues. I've got the BLOCK_BUFFER_SIZE at 64, MAX_CMD_SIZE at 96 and BUFSIZE at 32, TX_BUFFER_SIZE at 32serial.log (282.9 KB) octoprint log.log (38.6 KB)

Hello again,
i wanted to ask, if you maybe looked at the new log files that i uploaded and maybe have a clue what could cause my problem?

The only thing I can see is, that the printer passes away exactly at midnight.
Is it maybe connected to a time controlled outlet socket?

no :smile: think that was random. But i looked at the first log data again and it says:
Error:checksum mismatch, Last Line: 44630
| Recv: Resend: 44631
I was reading a little bit about that and it's a Octoprint problem since min. 5 Years... It is very complex and has to do with too much Data in quick time. Also i thought that 250000 Baud would help it actualy may be worse because the printer maybe reads the Data faster but that also means, that it has less time (40 micro seconds) to handle the input. In many times it can cause lost chars what can cause the problem.
But i don't have any real solution so far.... so i keep printing with SD card instead till i find a solution :frowning:

Has anyone found a solution to this? After flashing the most recent Marlin update to my printer my printer has started pausing randomly mid print. It leaves blobs at these stall prints and the extruder looses filament so it creates a tiny gap when it continues.

In my experience when printer is constantly pausing (for no apparent reason) while printing:

  1. You are running Marlin Firmware <-- 99% of the time I have observed this problem (I could not fix this issue on ANY printers with ANY control boards that I tried to put ANY version of Marlin on other than the ones that manufacturers had included, I ended up switching to Repetier firmware. By the way for me the issue was consistent and was happening with Repetier Host and Repetier Server running in Windows, and RPi, and not just OctoPrint).
  2. Firmware has issues, wrong settings, something is set to run too frequently, and slows things down, etc (not likely if you used the appropriate tool to configure the firmware, unless you were messing with the source code)
  3. Your control board or other hardware has issues, something doesn't get enough power, something is overheating, etc. (unlikely if your system has been working fine before)
  4. If this only happens on this specific print job and not others, then your Gcode has some issue.
1 Like

I have the same problem , small prints work fine but long prints stop after 3-4 hours , I noticed when the printer stops octopi is still showing its sending information in telemetry , I guess I will go back to SD card printing and just use the raspberry camera for remote monitor , I can shut the printer off and on remotely with my RF controlled power cord , been 3d printing around 6 years without any problems until I tried octopi.