Printer Stopping Randomly and disconnects from Octoprint

So what's happening is my printer gets an error for heater timeout and Octoprint disconnects from the printer and the webcam stops working but my printer still thinks it's printing and just sits there with the extruder not moving. This happens around the same time each night I cannot confirm if it is happening at the same time or if it is just a coincidence since I start prints after class and they error out after a few hours. Everything is being powered by a smart plug but I checked my HA log and it wasn't turned off.

I read another post that was kinda similar where their printer stopped at the same time every day and they re-installed their plugins and it fixed it but it didn't work for me.

I haven't tried running it in safe mode.

Systeminfo: (123.1 KB)

Printer Info:
Creality Cr 6-se
Octorpint Version 1.9.2
Running on rpi 4 8g

The last log only contains one of those errors so I can't tell you if they happened at the same time.

I don't see the heater timeout there, just a serial exception.

Please upload the the other octoprint.log logs so we can check that out.
Click on logs for further information on how to get them.

Sorry for the late reply, I haven't had much time until now. It keeps happening but I can confirm that it is not at the same time but I have figured out that either the pi is rebooting/crashing or disconnection from the printer because the web UI goes down and prompts me to log in after it reloads and it shows an error under the connection state. It is running on the standard pi power supply also.

No worries

Creality printers are known for having this kind of issue.
It's most of the time caused by EMI.
EMI can be emitted by a lot of things like fluorescent tubes, ACs, fridges and sometimes even when you sit down on an office chair with a gas cylinder in it.

Things you can try:

  • print with and without an sd card inserted into your printer (you don't need to print from the card - we just had some cases where it helped with some weird issues).

  • if you have something nearby that could cause EMI, you can try to place the printer in another location.

  • try a different USB cable - if possible one of good quality with ferrite bead.

Ok so I replayed the pi with another one I had and put it in a metal case. It was already powered with a Ferrell bead cable and the problem went away. So maybe the pi was dying or the metal case helped to shield the pi from interference but it works now and I have run over 100 hours already with it so it seems to be good.