Printer stops, Octopi restarts silently

What is the problem?

my printer occasionally stops mid printing. Sometimes early, sometimes late in the print, no pattern. Remarkable is, that bed and nozzle remain heated in this case. When checking Octopi, it appears to work though (paginate...)
IIRC Octopi is in safemode in this case (always, or sometimes, not sure)

What did you already try to solve it?

  • the printer is connected to the Raspi 4 with the USB Power pin blocked, so power is coming only from a trusty good PSU
  • rebooting Octoprint didn't help. Rebooting the entire Raspi "seems" to extend the time until the issue a bit. Completely disconnecting the Raspi from power for a while seems to work best, but still not reliably.
  • checked for overheating. Added a dedicated fan, just to be sure. No change.

Have you tried running in safe mode?

see above: it does come up in safemode anyway. But when printing in Safemode it still happens.

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (19.8 KB)

Serial Log is avilable, but was too big for uploading.
No difference in behaviour, if serial logging is enabled, or not.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

whenever this happens, the log shows the same pattern of messed up timestamps like here: entries from 19:03, then something from 19:18 and only later the obvious restart at 19:17.

Raspi is connected via LAN cable, not Wifi

Hello @reach !

2022-04-19 19:18:08,158 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2022-04-19 19:18:15,297 - octoprint.plugins.tracking - INFO - Sent tracking event ping, payload: {'octoprint_uptime': 620995, 'printer_state': 'OPERATIONAL'}
2022-04-19 19:17:07,585 - octoprint.startup - INFO - ******************************************************************************
2022-04-19 19:17:07,587 - octoprint.startup - INFO - Starting OctoPrint 1.7.3
2022-04-19 19:17:07,588 - octoprint.startup - INFO - ******************************************************************************
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                 2022-04-19 19:17:07,076 - octoprint.startup - INFO - ******************************************************************************
2022-04-19 19:17:07,078 - octoprint.startup - INFO - Starting OctoPrint 1.7.3
2022-04-19 19:17:07,079 - octoprint.startup - INFO - Starting in SAFE MODE. Third party plugins will be disabled!
2022-04-19 19:17:07,079 - octoprint.startup - INFO - Reason for safe mode: problem during last startup
2022-04-19 19:17:07,079 - octoprint.startup - INFO - ******************************************************************************
This looks like a lose wire or connector in the power supply chain.

Or just a very bad power supply unit

thanks for your help!
I'll swap the PSU and the cable and will observe and report back.
Just wondering: is this pattern in the log, with the timestamps going back and forward, a known one in this case?

Yes, during a power loss, the internal clock gets a bit corrupted and starts with a wrong time. When the OS can synchronize with the internet, it has the correct time again.

The RasPis do not have battery powered RTCs

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.