Printer stuck at 99% - Prusa MK3S+ MMU2S

What is the problem?

After a print is finished the Printhead moves to the parking position and shows "mmu needs user atention" and stops. A push on the knob ramps up the temps again and sometimes magical finish the job. But this keeps happening not only since the newest updates, it's there for about 3-4 mounths now. It occours on single and multiprints. I can't see any pattern at the moment. I'm not that hardcore printer user and not that experienced yet, but please advice me to test - I will do it. Just need a little time.

What did you already try to solve it?

Change firmware from printer, updated to several versions of octoprint/octopie

Have you tried running in safe mode?

No.

Did running in safe mode solve the problem?

Not tested yet.

Systeminfo Bundle

attached
octoprint-systeminfo-20211103064738.zip (3.2 MB)

Additional information about your setup

OctoPrint 1.7.1
Python 3.7.3
OctoPi 0.18.0

Prusa Slicer 2.3.3

Prusa MK3S+ -> FIRMWARE 3.10.0
MMU2S -> FIRMWARE 1.0.6

octoprint.log

What you are describing is the tip of the filament is getting jammed somewhere on the filament unload.
Since this isn't a problem with Octoprint, you will get better help on the Prusa forum.

To troubleshoot you need to know where you are jammed. If you unscrew the Festo Fitting on the top of the extruder you can see if the filament is still in the extruder or stuck in the PTFE tube. If the filament isn't in the tube then you are stuck in the selector or have a string of filament holding up the Finda Sensor.

Possible fixes:

  • Remove the finda sensor and clean out the area under the steel ball.
  • Dry your filament.
  • Try different filament types and adjust ramming settings for the filaments that are getting stuck.
1 Like

Hello @k7zpj ,
thank you for taking the time an reply to my problem.
I don't think actual that it comes from bad filament or a jam at the moment. I printed this 3 colour print


with a high rate of filament change and it also get only stuck at 99%. Thats why I think its somewhere software related.

After long trial and error I had to change the Control Board MMU2 and the F.I.N.D.A. sensor. Now it works again.