Printer stutters if you upload new models while it is printing

What is the problem?

If you upload new gcode while printing a model, if the model has a lot of short movements (like a circle), the printer will stutter severely while the gcode is being processed, causing tons of zits int he print. I'm printing with TPU so it is extra sensitive to this.

I have tried uploading new gcode while it is performing solid linear infill, and it didn't seem to stutter at all, but on circular model it was really bad.

What did you already try to solve it?

I have tried it on multiple Prusa MK3S+ printers, some connected to the PI using USB and one connected using the onboard searial pins, both with results.

Have you tried running in safe mode?

No

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint-systeminfo-20221116135558.zip (1.3 MB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Printers: Prusa MK3S+
Firmware: 3.10.0

OctoPrint Version: 1.7.3
OctoPi Version: 0.18

Raspberry PI: Model 4B 1.4 - 4GB Ram
SD Card: Samsung microSDHC UHS-I Card EVO Plus (32GB)

Hello @garyw !

This not recommended. It adds more load to the Pi's CPU.

Linear infill is not that high command density like an arc or other complex extrusions.

If you try to upload from PrusaSlicer or SuperSlicer to OctoPrint during printing action, it is denied by OctoPrint.

Hi Ewald,

I understand it can definitely add to the CPU... I use to have this problem when using Raspberry Pi 3 with 2GB ram, but after upgrading all my units (18 of them) to Raspberry Pi 4 with 4GB RAM I'm pretty sure I didn't have this problem. Its unfortunate Octoprint can handle this scenario, the more printers you have the more need there is to send production files to them while they may already be printing.

PrusaSlicer can send files to Octoprint and have Octoprint accept and process the files while a print is ongoing, as long as you select "Upload" instead of "Upload and Print", this is how I've come across this issue.

For now I will not send new print files while a print is going on.
Thanks!

Gary

I always use only Upload and always get the message that upload is not possible during print when I accidentality press Upload during print.