Printer Timing out when printing

serial.log (652.0 KB)

What is the problem?

Printer Timing out when printing i have a few different error messages but the most common is State: Offline after errorToo many consecutive timeouts, printer still connected and alive?

What did you already try to solve it?

I have tried running in safe mode and replacing usbs also tape over 5v on some usbs

Have you tried running in safe mode?

Did running in safe mode solve the problem?
I have and no

Additional information about your setup
I am running a Ender 3 pro with BLTouch, slient board, dual gear, glass bed and have the newest verison of Octopi/Print


why did you delete the template that opened when you wrote this post?
Please add a Systeminfo bundle.

2021-12-24 20:38:20,816 - Send: N0 M110 N0*125
2021-12-24 20:38:20,819 - Recv: ¶IÁPJ²YxrèºAÁHB²Yxrô²IÁPJ²YxrèºAÁHBªQ!TJºAÁTBªQpzð²IÁPJ¶Y%PJecho:Unknown command: "øàà"
2021-12-24 20:38:20,820 - WARNThe received line contains at least one null byte character at position 0, this hints at some data corruption going on

You can search the forum posts on Ender 3 Serial to find many reports on what gave people electromagnetic interference, some even ran into problems after pushing the ribbon cable between the board and the lcd display into a nicer looking path.
An aircon, fluorescent tube, refrigerator or electro motor can create interference.

Interestingly your serial.log seems to shows few sharp noise events

Thanks for the reply.
I must of missed that and deleted that part of the template by mistake my bad will add it now.
Also what do you mean by Sharp noise events. I have a Fridge in the room but not too close to the printer also a hydroponics. Recently i have removed a wifi plug that was in the same (1.1 MB)

Some serial logs show lines and lines of garbage but the one you posted has like 3 one-liners.

A fridge can be a mighty disturber, I control the lights in my apartment with PIR sensors and the fridge was able to turn the lights on in kitchen and hall when it started and stopped by inducing false signals in the sensors. But a you can hear the compressor running you have a good chance to hear if the errors in printer communication correlate with the fridge running.

serial (1).zip (1.1 MB)
I have changed the power cable and usb now i am getting this error. SerialException: device reports readiness to read but returned no data (device disconnected or multiple access on port?) I have provided a updated log

Since my initial installation of Octoprint in October of this year I could successfully complete short prints but would often have longer prints stop mid-print due to the communication timeout issues. I went through all of the troubleshooting recommendations including increasing timeout settings, changing USB cables and adding additional ferrite beads for noise filtering, relocating the PI further from the printer, masking the 5V pin on the USB cable, etc. This weekend I solved my problem. It was in fact electromagnetic interference but not through the USB cable but through the power supply cable. When I set up my Pi I got fancy and mounted the dedicated Pi power supply under the printer and connected it to the 120v input lugs on my printer's PS for a "clean" install. The Pi PS's cable was then routed around the printer's PS and then out from under the printer to connect to the Pi. Removing the PS from under the printer and plugging it into a normal 120v receptacle solved the problem. I have successfully completed 3 "dry-cycled" or should I say "cold-cycled" 5 hour prints with no communication errors or resends.

I focused too much and for too long on the USB cable length, shielding, location, and filtering. Based on other's advice and experience USB cables are definitely a primary issue for communication errors but wanted to share that noise coming in via the USB-C power port on the Pi is also a real source of problems as well and should be addressed early in the troubleshooting process.

Thanks to the many who have posted help on solving comm issues. Glenn


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.