Printer won't connect, lots of "AP 409 GET" errors


#1

What is the problem?
Octoprint won't conect to my printer...can't detect the serial port. Serial port is on COM2 and driven bya "CH340" driver that I can see in Device Manager.

What did you already try to solve it?
I( changed the COM port in device manager - no effrct.
Restarted PC - similarly no effect.
Changes baud rate in settingsfor Com port - no effect

Additional information about your setup
(OctoPrint version 1.3.7, OctoPi version n/a, printer A8 Anet, firmware standard, octoprint.log, serial.log or output on terminal tab, ...)

in the window for Octoprint itself I am getting MULTIPLE "Tornado Access warning 409 Get API /printer (127.0.0.1) 1.0ms)

I run Octoprint just on my PC with no other dvidce.

Hope someone can get me back online/...if not it's back to the SD card!


#2

In the octoprint web interface on the left side under the Connection drop down (you might have too click the word connection to get it to display) try toggling Serial Port and Baudrate between the available options. Ive had similar issues with a ch340g and this method worked for me. Also you could check out the settings and attempt too manually add the Serial port too the Additional Serial ports setting.


#3

Done all that, regrettably to no effect. Might try reinstalling driver...