Printer won't connect / state blank / terminal blank

What is the problem?

Suddently, when I go to octopi.local, the server will connect, but the printer won't. The "state" field is blank and the button shown above is "Disconnect", but clicking on it does nothing. The terminal tab is also blank.

This is on a macbook. What is weird is that it works fine under a user "parent's" but doesn't work on a parental controlled user. It worked fine before, but stopped working today under this parental controlled user.

What did you already try to solve it?

I troubleshoot by logging in into a different user in my mac and octopi.local was able to connect to the printer. The problem is with an specific user account within my mac. This account is for a minor so it is parental controlled. However, I even remove all restrictions to websites under the parental control menu, with no luck. I tried logging out and logging back in with the same unsuccessful result.

Have you tried running in safe mode?

Yes, same problem.

Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint.log (45.0 KB)
plugin_softwareupdate_console.log (1.6 KB)


Additional information about your setup

OctoPrint version 1.8.1
Octopi Version 0.18.0, running on Raspberry Pi 3 Model B Plus Rev 1.3
Printer: Ender 5 Plus
Firmware: don't know where to look at this...
Browser: Safari and Chrome (same problem on both)
OS: HighSierra

Hello @danramos !

Have you tried different USB cables. Not everyone is able to transfer data.

the problem only occurs under a minor's account in my macbook. It works fine on my account, even from safari in my ipad or iphone. So it is not the usb connection between the printer and the Pi. It must be some sort of configuration within the user account in the macbook.

It looks like the websocket is never able to establish a stable connection with the server, so it can't get all the info it needs. The log is full of cycles of new connection -> logging in -> connection closed.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.