Printhead stop & Go

This is

  • OctoPrint 1.8.4
  • Python 3.7.3
  • OctoPi 0.18.0
    on a raspi3b with an Ender 3 running Marvin (last reconfig on 24.11.21)

No changes on the firmware or raspi since half a year or more other than occasional apt updates and octoprint version updates.

3d-printing had paused for 2 months and as I started again I found an issue which I read about here a while ago. But of course cannot find the old post.

The printer doesn't run smoothly and in a continous way, instead it prints a bit, then stalls, waits for something, then comes the next bit, stalls again, etc.
While the printHead stalls filament oozes out so the surface of walls is a mess. Print times are longer than they should be.
Oh, it is not just the printHead, all axises, including the extruder show the same stop&go behaviour.

What did you already try to solve it?

I took a look into the serial.log but nothing caught my eye. No 'funny chars' garbage indicating transmission errors.
Restarting the service did not change anything.
Safe mode didn't change anything.
Slicing the model with a different slicer (cura 4/5) didnt change anything.
Reboot didn't change anything.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Unfortunately, no change.

Systeminfo Bundle (822.0 KB)

Additional information about your setup

had been rather stable system this year.

Does this also occur when you print from SD card?

Try disabling DisplayLayerProgress and see if it's the same. I see you ran in safe mode, a day before the bundle creation, so that would have disabled the plugin, but the log appears to have rolled over in that bundle so don't have anything from during the safe mode run. Either way, even printing from SD card is possible to produce blobs depending on your printer. There an interesting video I've seen before in regard to that but this one recently posted in my feed relative to power loss recovery. They also touch on slicer settings that could be adjusted to reduce the amount of segments in arcs, and of course if your printer supports it arc welder could also help.

1 Like

Saw another recent post that the resource monitor plugin was the cause. Disable it and the pauses go away

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.