Printing via octoprint is much/to fast compared to SD card

Dear all,

I am completely new to octoprint and I have a probably easy problem:

When I print a file via octoprint the speeds are way to high and the steppers are loosing steps.
Printing from SD card is (still) working properly

Cura 4.12.1 slicing for both octoprint and SD card
newest Octoprint 1.7.2
Ender 3 with Bigtreetech SKR mini E3 and Marlin

There were some warnings from "Octolapse", which I ignored

Thanks a lot for your input

Hello @berndhac !

You also ignored the template that was there and that asked you for some information that help us to help you. (E.g. systeminfo bundle, safe mode)

1 Like

And it would make sense to enable Serial.log -ging and, with logging enabled, reproduce the issue so the log captures the communication between OctoPrint and the printer. After that been done obtain and upload the systeminfo bundle, thanks in advance

1 Like

thank you for your response and please excuse the missing files ...

I did a print in Safe Mode and it was still to fast. (58.4 KB)
serial.log (148 Bytes)

60MM_circular_honeycomb_Flat.gcode (768.6 KB)

Thanks a lot

Hi everybody,
I have an update/addition:
Today I printed from SD-Card but with octoprint connected before the print was started. Again it was way more agressive in acceleration and there where massive layer shifts.

Thanks a lot for your help

Have you tried safe mode?

1 Like

Yes, I tried safe mode - same result

you have to turn on the serial log in settings -> serial connection -> common and scroll all the way down and check the box. then sart a new print attempt. When you dont enable serial.log the serial.log file is empty

1 Like

I did two more prints (Bed level and Benchy).
Speed looked surprinsingly ok.

Nevertheless I attached the new serial.log (first 4MB) serial_2021-12-18_part.log (3.6 MB)
and Systeminfo. (2.1 MB)

Thanks a lot

Im not completely sure, but the commands at line 427:

2021-12-18 10:09:33,110 - Send: N9 M201 X500.00 Y500.00 Z100.00 E5000.00*3
2021-12-18 10:09:33,113 - Recv: ok
2021-12-18 10:09:33,116 - Send: N10 M203 X500.00 Y500.00 Z10.00 E50.00*9
2021-12-18 10:09:33,119 - Recv: ok
2021-12-18 10:09:33,122 - Send: N11 M204 P500.00 R1000.00 T500.00*76
2021-12-18 10:09:33,125 - Recv: ok
2021-12-18 10:09:33,128 - Send: N12 M205 X8.00 Y8.00 Z0.40 E5.00*8
2021-12-18 10:09:33,131 - Recv: ok
2021-12-18 10:09:33,134 - Send: N13 M220 S100*83
2021-12-18 10:09:33,137 - Recv: ok

These are speed and acceleration controles. it should have sth to do with these lines. When you don't set them for a specific reason i would delete them in your gcode file and restart the printer. But i'm not so familiar with these commands. maybe there is someone who can interprete these commands better.

1 Like

A good reference is this:

here a small update:
yesterday and this morning I made two prints via octoprint without an issue.
Today another bigger print with again hard accelerations, layer shifts and hot steppers. I measured the stepper temperature with an IR probe. X-stepper was 84°C, y-stepper around 70°C with a room temperature of below 15°C.

Thanks a lot

You should check/adjust the motor current. It is to assume, that the drivers get too hot too.

1 Like

Thanks for your response.

The motor current is "stock".
The point is, that one print was perfekt (I did not measure stepper temperature) - sound was good, result was good:

And the next print was not working at all. I nooticed a probably motor induce roaring sound as well.

The only difference between the prints I can imagine was the running Timelaps at the horse and maybe a different order powering on the Pi and the printer.
Same printer, same firmware, same slicersettings

Thanks a lot

Hi again,
I started the same print with the horse an hour ago:
I used the file on the Pi from yesterday
first powered up the printer, after that the Pi
restartet Pi in safe mode and timelaps disabled

Print looks fine and steppers are around 30°C.

When the print is finished in several hours I will only change one parameter and not so many at the same time ...

Thanks a lot

I had same issue. Octolapse (0.4.1) with setting soft(MP4) was the problem. Head was moved not smooth but with jumps. I printed several times and finaly after disambling Octolapse everything is OK. Resource monitor showing CPU usage between 5 an 8%. Maybe the problem is mane writes on SD?
Yellow thing is printed with octolapse - its spliting apart. The same file without octolapse is OK.
Prusa i3mk3s

1 Like

Hi Tom,
thanks for your input - sounds familiar.

For the past days the printer is running around 10h each day, without timelaps (neither octolaps or any other timelaps) and without problems.
I should probably reinstall everything without octolaps and try again.

The only issue I have quite often:
The Pi loses Wifi-Connection - sometimes when the screensaver from the computer started, sometimes in between, sometimes not. Most of the time after some minutes and reloading the page in the browser it works again. With Octopod on the iPhone it is the same ...

Thanks a lot

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.