PrintrBot Zprobe not homing


#1

Hi, I'm trying to setup Octoprint with my Printrbot Simple Metal. Everything is working, except that I cannot get the bed-levelling to detect.

It does work in Cura directly from my laptop, so the leveller is working, and when I used the slicer plugin it seemed to work, but when I import a Gcode file it does not work.

This is the response I get on the M119 code:
Send: M119
Recv: Reporting endstop status
Recv: x_min: TRIGGERED
Recv: y_max: TRIGGERED
Recv: z_min: open
Recv: ok

G28 gives me this result, but the Z probe is 2cm above the bed:
Send: G28 X0 Y0 Z0
Recv: echo:ZProbe Outside Bed
Recv: ok

I have Printerbot Simple Metal, and This is my machine firmware:
Send: M115
Recv: FIRMWARE_NAME: Marlin V1 FIRMWARE_URL: PROTOCOL_VERSION: 1.0 MACHINE_TYPE: Printrbot Simple EXTRUDER_COUNT: 1

Any help would be greatly appreciated!


#2

Is it a probe or an IR sensor? Mine (Robo 3D) samples nine points on the bed and never touches the bed—it moves slightly up/down each time, measuring the reflection presumably.

Did you go through the obligatory "what do others do in this case?" exploration on youtube?


#3

It's an inductive probe.

Yeah, I googled the heck out of it, also checked out the Printrbot talk forum. All of those video's refer to z-axis calibration and issues when connected directly to Cura, mine works when connected to Cura, just not working via Octoprint.


#4

Have you tried homing the x/y/z before doing all this? On the OctoPrint Control screen, push both home buttons.


#5

Hi,

Yes, that's where I first picked up the problem. So if I click x&y home, everything is fine, it homes perfectly, but if I hit z axis there is no response and in terminal I get Recv: echo:ZProbe Outside Bed

The inductive probe is detecting the bed, as I mentioned, a connection direct to Cure on my laptop homes perfectly.


#7

You might want to check your OctoPrint -> Settings -> Printer Profile for this to verify that it knows how big your X/Y/Z are.

reference link


#8

Hi,

I only get to use my printer on the weekends!

I checked, th printer profile is showing the correct bed size. I'm pretty certain it has something to do with Octoprint or my Marling board not communicating the inductive sensor of the z axis


#9

There should be a light which indicates that the inductive probe sees (presumably) metal underneath it. In theory, placing a pair of needle-nose pliers under the probe should trigger the light. If it doesn't, then this is more of a hardware and connections sort of problem. Also, the light should be off when it's not triggered by proximity.

It's possible that the switch simply isn't connected and therefore is always open. There could be a safety mechanism which says essentially: "I've moved close enough to have seen the bed but I didn't. I'm aborting and not moving any closer."

Many ways of improperly assembling this


#10

Hi,

I think the inductor is fine, it's detecting both metal object and that plate, and as I mentioned it's printing fine directly from Cura on my laptop.


#11

This is what you posted that the M119 returned. If the bed is raised (or the extruder lowered) as you've described, then it should be triggered instead. OctoPrint just relays those responses in the Serial tab. It doesn't sound like OctoPrint saw "TRIGGERED" and then replaced that with "open" before showing you the result.

I don't know what else to tell you other than to check your printer profile settings.


#12

I realize this may be a day late and a dollar short, but I've discovered that if I input the G28 homing code at the terminal, my printer will home the Z axis. Mine uses an inductive sensor and it works well.
The INTERESTING part here is that the Z home button DOESN'T work until AFTER I use the G28 code. After the initial use of the G28 on the terminal tab, I can use the Z home button on the control tab and it works just fine.

Maybe there's somewhere in the settings where one can tell Octoprint to use the G28 code??