Prints hanging on Starting

What is the problem?

I am unable to start prints reliably. They get stuck at heating for seemingly long time(12 minutes) This issue was experinced on RPi3 and RPi4. I was running Klipper successfully for a long time, with disabled bed heat wait, but today i went back to Marlin and the issue reappeared.

What did you already try to solve it?

I tried to disable wait for heatup, stopped plugins, ran in safe mode

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (2.2 MB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

latest octoprint version, Sidewinder X1, Matrix extruder, TMC2209 running Marlin

Hey :slight_smile:

Please enable serial logging and try to reproduce the issue.
Then upload another systeminfo bundle. Hopefully we can see what's going on in the serial.log :slight_smile:

There we have it. Started a print, waited a long time with no start. Canceled, started anew and it started immediatelly. Looks like the start Gcode doesn't get send (2.3 MB)

What I see is a quite strong temperature overshooting of tool and bed.
Both need quite a time to settle to their desired temperatures.

I recommend to run a PID auto tune for the tool and the bed:

1 Like

That was the first thing I did after putting Marlin on. Did PID twice on both bed and hotend then moved on to steps.

With PID, that should look smoother.

Also just found this in the serial.log

2022-01-22 07:55:52,765 - Send: N8 M140 S[first_layer_bed_temperature]*18
2022-01-22 07:55:52,774 - Recv: ok
2022-01-22 07:55:52,777 - Send: N9 M104 S[first_layer_temperature]*47
2022-01-22 07:55:52,783 - Recv: ok
2022-01-22 07:55:52,785 - Send: N10 M109 S[first_layer_temperature]*26

These terms: [first_layer_temperature] should be numbers.
Either your slicer can't translate them or they are in OctoPrint's startup gcode section?

1 Like

It's possible. When I was on Kliipper the AC bed was overshooting a lot, thats why I disabled wait for it. Klipper PID algorithm, was not helpful. It's a known issue with beds that cool slower than they heat up.

On older Marlin versions I had pretty stable PID settings for both hotend and bed(same hardware) Maybe they changed something in the algos, as they did with the direction for all motors.

As for the startup gcode- I've tried multiple versions, some with or without those lines. I'll get them sorted. It's a problem alright, but not the main issue, as in fact prints start with that gcode when it's actually being sent.

For the PID of the hotend: It may work a bit better by using a silicone sock.

I'm running a T-Rex 3 with a 40cm x 40cm AC heated bed on Klipper for some time now. The PID works fine for it.

1 Like

I have always been using a sock.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.