Problem after installing Klipper (after disabling IPV6 on RPI)


#1

Hi all,

I installed Octoprint (Octopi last version) 5 days ago, seems that the WebServer was working well .. (did not touch too much to the config ..)
Now, have some time to install Klipper on my Trigorilla ..

And then, the Klipper script execute a .. "sudo apt-get update" ..

But it was soo slow .. I discovered the fault was with the IPV6 enabled ..

I decide too disable the IPV6 ...

Then APt-get was working perfecly ... I flashed the Trigorilla ..

Then try to connect again to the Octoprint web page ... and I received several "Server offline" popup ..

Ssh to my RPI is working well ...

I read on different forums ..
Check the logs ... and see in /var/log/haproxy.log

May 27 20:37:38 octopi haproxy-systemd-wrapper[532]: [ALERT] 146/203738 (535) : Starting frontend public: cannot create listening socket [:::80]
May 27 20:37:38 octopi haproxy-systemd-wrapper[532]: [ALERT] 146/203738 (535) : Starting frontend public: cannot create listening socket [:::443]
May 27 20:37:38 octopi haproxy-systemd-wrapper[532]: haproxy-systemd-wrapper: exit, haproxy RC=1
May 27 20:37:38 octopi haproxy-systemd-wrapper[556]: haproxy-systemd-wrapper: executing /usr/sbin/haproxy -f /etc/haproxy/haproxy.cfg -p /run/haproxy.pid -Ds
May 27 20:37:38 octopi haproxy-systemd-wrapper[556]: [WARNING] 146/203738 (558) : Setting tune.ssl.default-dh-param to 1024 by default, if your workload permits it you should set it to at least 2048. Please set a value >= 1024 to make this warning disappear.

Any ideas ? is link to the fact IPV6 = disable ? (after Octopi installation ?)

I can see the process :

pi@octopi:~ $ ps waxu | grep haproxy
pi         735  0.0  0.0   4372   552 pts/0    S+   20:54   0:00 grep --color=auto haproxy

Thanks in advance for any help

Regards

Didier


#2

After some search ...

Seems in the /etc/haproxy/haproxy.cfg ... the IP v4 & v6 is mentioned ..

frontend public
        bind :::80 v4v6
        bind :::443 v4v6 ssl crt /etc/ssl/snakeoil.pem
        option forwardfor except 127.0.0.1
        use_backend webcam if { path_beg /webcam/ }
        default_backend octoprint

I changed with :

        bind *:80
        bind *:443 ssl crt /etc/ssl/snakeoil.pem

then restart the service ..

now, i can connect .. but still have the warning ...

[WARNING] 146/215638 (1243) : Setting tune.ssl.default-dh-param to 1024 by default, if your workload permits it you should set it to at least 2048. Please set a value >= 1024 to make this warning disappear.

think the problem is solved ..


#3

If you really want to get rid of the warning, add:

        tune.ssl.default-dh-param 1024

to the global section of /etc/haproxy/haproxy.cfg


Sharing RPI between OctoPrint and Klipper
#4

It would be great to eventually come up with a how-to for updating Marlin and OctoPi for Klipper. I know from second-hand experience that it moves enough of the work over to the Raspi 3 so that the RAMPS board is never overloaded (resulting in short-duration stalls which themselves probably produce surface blobbing).