Problem Connecting to Printer (Ecubmaker toydiy 4in1)

What is the problem?

so I've recently gotten a pi4 first thing i did was install octopi and no matter what i try to do it just wont stay connected

What did you already try to solve it?

Starting without the SD card
and this plugin i saw from a similar post Malyan/Monoprice Connection Fix
also using wait for start as well

Have you tried running in safe mode?


Did running in safe mode solve the problem?

no it didnt it did the same error

Systeminfo Bundle (38.3 KB)

Additional information about your setup

OctoPrint 1.7.2, OctoPi 0.18.0, printer EcubMaker TOYDIY 4-in-1 , on the printer is 1.9.2, microsoft edge, windows 10, ... as much data as possible

also heres my logs (127.3 KB)


Thanks for turning on serial logging - most users forget that :slight_smile:

I think the problem is, that your printer gives non standard responses
Octoprint expects your printer to answer like this

Send: N2 M21*18
Recv: echo:No SD card
Recv: ok N2 P63 B127

Your printer is answering like this

Send: N2 M21*18
Recv: ok N1 P15 B3echo:SD init fail`

Two lines are combined into one.

First you should try other usb cables.. There it could just be a transmission error.

If that doesn't help you could try to fake the ok responses and see if that helps - but that's not really a solution.

Either clicker on the blue bar in the advanced options in the terminal tab
Bildschirmfoto vom 2021-11-19 03-01-16

or switch this (Settings --> Serial Connection --> Firmware & protocol --> Advanced options)

to always

I doubt that it will work for much longer because other outputs like temperature are probably also affected.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.