Problem installing desktop with 0.18.0 release

I cannot get the desktop to install & launch for Octoprint v0.18.0. I tried this -


  • Raspberry Pi 4
  • Sandisk 16GB


  1. Install: Imager v1.6.2->Other Specific Purpose OS->OctoPi
    *Ctrl+Shift+X to set custom pswd & wifi
  2. Power on w/HDMI, mouse & keyboard
  3. Connect via PuTTy over WiFi
  4. Term (sudo /home/pi/scripts/install-desktop)
  5. Reboot (Claims no session manager)

I have tried some options but can't get this up. Is desktop supported for v0.18.0?

1 Like

Without any output of the install-desktop command to see if there was any problem during the installation, it is a bit hard to help you out....

thanks much, be right back

I followed the procedure above, yielding -

Here is another step I debugged with tonight, repeated again. I rebooted, connected PuTTy and -

  • sudo raspi-config->#3.Interface Options->P3.VNC = Yes
  • raspi-config vnc attempt.txt -> "There was an error running option P3 VNC"


Looking through the output, there are some lines that show 404 errors, so some package weren't downloaded, and as such, installation didn't proceed. There's also this line :
E: Repository ' buster InRelease' changed its 'Suite' value from 'stable' to 'oldstable'
To correct this, you need to run sudo apt-get update --allow-releaseinfo-change .

The 404 errors also happened when trying to install VNC, so no packages were installed as well...

Although I'm not really sure why you want to install a desktop environment if you're setting up VNC afterwards. OctoPrint is reachable using any internet browser from a computer on the same network as the Pi...


I want to use this OctoPi unit to also serve as a Home NAS, Smart Home interface and really - just an opportunity to tinker and learn

thx, back soon :relaxed:

It works! Here was my final procedure -


  • Raspberry Pi 4
  • Sandisk 16GB


  1. Install: Imager v1.6.2->Other Specific Purpose OS->OctoPi
    *Ctrl+Shift+X to set custom pswd & wifi
  2. Power on w/HDMI, mouse & keyboard
  3. Connect via PuTTy over WiFi
  4. Term (sudo apt-get update --allow-releaseinfo-change)
  5. Term (sudo /home/pi/scripts/install-desktop)
  6. Term (sudo reboot)
  7. Term (sudo apt update)
  8. Term (sudo apt install xinit lightdm)
  9. Term (sudo apt install realvnc-vnc-server)
  10. Term (sudo reboot)
  11. PuTTy confirm access
  12. RealVNC confirm (

Now it works, over HDMI and VNC. Thank you @SwHawk!! :pray:

Glad you could make it work. Have fun printing and tinkering. If you need help setting up the other software you talked about (especially NAS), you could always find me on the discord server for octoprint. Other people will be glad to help you there as well

1 Like

Just remember that the more "other" software you install on OctoPi (or your system that runs OctoPrint), the more likely it is that you will have anomalies (like zits and blobs) in your 3D prints.

1 Like

I followed these instructions carefully twice and ended up looking at a non blinking cursor in the top left corner of a black screen. Very difficult to go "startx" when there is nowhere to put it.

The installation appeared to go smoothly without the 404s encountered using the "official" instructions.

I did see the whole bootup text cascade on startup and a splash screen welcoming me to the desktop before the black screen appeared.

Raspberry Pi 4
Using the latest published image for Pi4 before any updates. Totally fresh.

Any ideas?

edit: I was a little unclear where I was. That image I refer to is from PandaPi so I really don't know what that means except that I have the same issue with it.

@TharnLago, You would probably get a better, more specific answer if you took the time to open your own Get Help topic adding specific details of exactly what YOU did and what errors YOU received. Note that "latest" doesn't convey nearly as much information as a specific version number (and source).

As the problem is PRECISELY the same and the software is also the same and the situation is the same and the error messages are the same and once again it is the same software - I think the thread in which it is discussed is the correct thread.

The fact that you do not personally have any answers is not a disappointment or surprise to me, but I hope that someone else might recognize the "black screen and cursor" state since it has been mentioned before and surely occurred for more than just me and this guy: OctoPi GUI Setup - #8 by KenLucke

You will note that that thread then becomes this thread. I am in the right place.

Are you able to be helpful?

The thing is, this is not the same, as the thread you mentionned actually had an error, and he actually told us specifically having 404 errors during the installation script, that's why I linked to this thread as it might help him.

Unfortunately, you didn't seem to encounter those 404 errors, and the non blinking cursor can be pretty much anything. It would actually be better to start a new thread since your problem is not exactly the same, and this one was marked as solved. We would need some logs to look over. You could access a command line terminal pressing ctrl + alt + F1 or F2 all the way to F6 until you see a prompt for a username. Then you'd be able to connect to the command line, then run the startx command, and show us if any error occur.

Without any such information we won't be able to help you... Also, people here try to be the most helpful to you, even when they tell you to start a new thread, there's no need to be aggressive or condescending... We're users just like you, and being like this isn't the strongest motivator to help you out...

1 Like

Oh, but I did encounter those 404 errors in exactly the same way.

And thanks for your attempt at a helpful hint. Unfortunately, those key combinations have no effect.

As for "aggression", well I don't know what you are talking about. I will, however, note that the only response I received was entirely unnecessary. As was his previous post about how your Pi is going to run slow because you installed things which is clearly erroneous. Installation has no effect beyond disk space. To say otherwise without clarification is simply FUD.

So, I was not feeling particularly grateful about further unnecessary commentary by the same agent.
Next he'll be extolling the virtues of "turning it off and then back on again".
You might consider that motivation goes both ways. I might be motivated or demotivated by the very first response received on your forum. Clearly you would like more forum members in general terms. I wonder how you motivate people to stick around? Give them a venue in which to hear themselves speak?

So in fact you are not using the same image as the OP, you can‘t have the same issue, just seeing the same symptoms…

You’d better give the original image a try….



this feels a bit aggressive on the receiving end, but that's a debate for another thread. Besides, two people who've actually been on this forum for some time telling you to open another thread, you might want to take that into account.


running NAS or Smart Home Interface as mentionned by the user who started the thread can be either network, RAM or CPU intensive, especially combined with a desktop interface and VNC remote access... @b-morgan was simply making the OP aware that those services may impact the quality of his prints, as these resources can become scarce on a Pi, depending on the model.

Excuse me then, but I seem to have misread your previous posts.

This is not my forums, as I told you earlier, I'm just a regular OctoPrint user trying to help you out, especially with the scant information you've provided.

So as to the help I'm providing, since those key combination don't seem to provide any terminal, you'll have to use another computer on your network to gain remote access to the Pi using SSH. If you have a computer running Linux (any kind really), that's as easy as running ssh <username>@<PI-IP-ADDRESS> or if you have a Windows computer, you would need to install PuTTY and then use this software to ssh into your Pi. Once there, if you could give us the contents of the /var/log/messages file, that may help us determine what the problem actually is.

Also as @hmerk suggested, you're using another distribution, which is why we told you to open another thread... Also why I can't provide more specific information about the usernames and password as I'm not familiar with PandaPi...


Thanks for trying, but I dislike seeing you waste your time as much as wasting my time.

You typed a lot and I have to appreciate that, but really all I wanted was someone who has actually seen what I see (the dead terminal). Suggestions about putty (using it all day) and Windows (don't use it) are just resulting in a lot of frustration and typing.

I will give up and simply make a dedicated interface machine with a separate Pi. That works fine and is a smaller cost than the time spent telling each other pointless things.

I am, once again, sorry for asking a question on the internet. I promise to never do so again.

@TharnLago, I'm sorry you consider my responses as "unnecessary" and that you consider your first interchange on this forum as a "waste of time".

It's more passive aggression than regular aggression.
It's the little things. Someone tries to help you and you call it an attempt to help you, you call things people need to know in order to help you unnecessary.

You're using a different image, but you claim to have precisely the same issue - but the solution for precisely this issue doesn't work for you - which indicates it's not precisely the same issue.

and that's just disrespectful.

That's not the way we want to hold discussions here in this forum.
You might want to read - Code of Conduct and internalize it or search for another forum where nobody cares about how people talk to valued members of their community.

Since OP solved his problem and you wanted to try another way I'm closing this thread now.