Problem using octoprint on my rPi

#1

What is the problem?
every time i boot the raspberry pi with octoprint, it asks for login and password. Im new to this so Im at a loss.

What did you already try to solve it?
tried the usual, no luck with any of it.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
Downloaded it tonight so should be latest version. As i said, im new to this and the pi, so maybe just newbee problems. Im also 65 years old, and not used the the linix command structure.

#2

Hello @freejac1!

This is a security feature. If you are inside a secure network, you can switch this prompting off:
Go to Settings (the wrench in the top line)
In the popup that appeards, on the left you go to Plugin Manager
In the main area you seek for Force Login
On the right you see a waste bin. Just left to it, there is a slider that can switch off this feature.

But be sure what you are doing. It's on your own risk.

#3

I think you may have a slight misunderstanding of OctoPrint. By and of itself, it is a server, and the user interface of that server is displayed in a browser (typically on another computer on the same network). By default, a screen attached to the raspberry pi is not supposed to show an interface.

You can install a desktop on the raspberry pi, and you can run a browser on that desktop. That browser can be used to show the OctoPrint interface. But this is not configured by default.