Problem with cr10s pro v2

I have a problem with octoprint in combination with my cr10s Pro V2. As soon as I have started the raspberry and turn on the printer the y-axis starts to rotate until the end of the stroke and the motor skips steps logically. Quickly turned off the printer. Restarted, the x axis starts to rotate very slowly. I cut the 5v wire of the usb cable so that the control only turns on when you start the printer and not via the raspberry. That didn't help. Does anyone have experience with this, and what could be the solution?

Yep - my Ender 3 did exactly the same thing. It's some weird bug in the firmware of the printer.

I suggest you update to a newer version. Either make your own, get a prebuild one from the internet or get one from creality.

1 Like

can you give me an advice which i can use? for me this is the first time i am going to update the firmware.

Yes - I'll try to put a little tutorial together for you later. :slight_smile:

thank you .

I was about to suggest that you build your own firmware with the help of this guide

But there is a catch:

Touch Screen Models Note: The CR-10S Pro came with factory touch screens that are not able to be controlled by Marlin. These printers are only compatible with this firmware when they have been upgraded with our LCD conversion kits.

Then I found a firmware from Tiny Machines which seems to be the right thing for you. :slight_smile:

Here is the guide

The firmware for the printer

The firmware for the screen

In the document you will also find links to videos which should help you more in detail.

Unfortunately I can't help you with the touch screen part because I don't have one - but I hope that the videos answer all your questions :slight_smile:

Have you fixed this problem ? I have the same printer and the same problem ! Thanks !

What firmware are you running?

no that didn't work. tried to update it with tiny machines firmware, but now several touchscreen functions no longer work. I am now adapting it to a duet2 with reprap firmware

Alright , I sent an email directly to the Creality Tech Support , will see what they will answer , i asked them if it was possible to take a look to this issue , and if they can fix it with a firmware update ..... will see, who dont try wont get any chances .

Did you solved the problem ?
Are there any info from Creality ?

1 Like

I have gotten a CR-10S Pro V2 two days ago, and was thinking to run octoprint (primarily for remote camera and shutdown support) on it, but the I read here people have troubles with it. Is this a common issue for ALL CR-10s PRO V2s? Or just some firmwares?
I have FW 1.70.0 BL on mine.
Will I get the same issues? (I know I could just try, but if its a known issue with all CR-10S PRO V2s, then i'd rather stay away until there is a solution. I'm new to 3d printing, and don't wanna mess something up :slight_smile: )
Will running the FW from MicroMachines make Octoprint work with this printer?

I had al lot of issues, temperatures ar not correct from the bed and nozzle. And also problematiek with octoprint it dont work for me. I build a duet 2 motherboard in my printer with bondtech lgx extruder and mosquito magnum

Did anyone managed the issue with the M600 command? I have a CR10sProV2 and I tried the pause at layer height on Cura and also the colour change (M600) on Prusa Slicer, however this never worked and completely didn't care about the command and completed printing normally as if there was no command sent.

Is there something to update the firmware so the printer can now identify M600 commands?

To be kind, Creality firmware is a mess. What started out as Marlin has been bastardized by adding numerous bugs and other anomalies. Unfortunately, this puts an additional burden on their customers by adding "find and update the firmware" to the list of skills required to be successful with their printers.

Earlier posts in this thread and other topics in the forum have pointers and instructions on how to find and update the firmware.

Above some mentioned the (Tiny machine and th3d) firmware upgrades. There was advised on the Tiny machine upgrades that if you didn't upgraded the BlTouch you dont need to do anything and do no firmware update.

If I do the firmware update for the Marlin 2.0 with the new touchscreen that tinymachine sells, I will be safe with upgrading or is there a chance that I can brick my printer?

You pretty much can't 'brick' the printer by flashing different firmware to it, since you can just flash it again until it works :slightly_smiling_face:

So to be on the safe side, you need a copy of the working firmware currently, so that you could put it back if the new one does not work.

With 32 bit boards it's even easier to flash, but I don't know which one your printer has.

I have have the Cr10sProV2, how can I back up the firmware that is on it? Or maybe will be on the Creality website right?

1 Like

Has anyone tried if Astroprint work with this printer ?
I read that maybe in can be alternative for us.

Astroprint is a fork of OctoPrint: