Problem with Octoprint remote access and dynamic IP

I configured my Raspberry and Octoprint to use remote access with the Weaved.

Everything is ok with the exception that the IP is changed from time to time. It´s not a static IP.

This way I need to change frequently, too, the IP provided by Remot3.

I´m using the last Octoprint version.

What I´m doing wrong?



Do you know anything about your home router/modem? You have two options.

  1. Assign a permanent IP address to your RasPi in it's configuration.
  2. "Reserve" the RasPi's address in order that it "sticks" and a new one doesn't get assigned periodically.

The second option is the easiest to do without having to change RasPi configuration files. Open your router and find the DHCP section. In there you will find a list of currently connected devices and their IP addresses. You need to set a reservation on the Pi's address in order that it always gets assigned the same address when it's lease expires.

Hi Norman

Sorry, I forgot to mention...
I used the option 2. I reserved an IP address to the Raspberry at the DHCP section.
Here, at the local network, the IP is static. The problem is that it becomes dynamic at the Remot3 server.


If it's the external IP address that you're concerned about you can ask your ISP about a "nailed" (static) IP. or subscribe to one of the Dynamic DNS services like

Norman, the problem is that here, in Brazil, the most ISP companies keeps the ports closed and we can´t use them for these services. I will read about "noip". Thanks again!

If your ISP blocks the incoming traffic then you may want to consider one of the plugins that middle-mans the communication between the internet and OctoPrint. Something like the AstroPrint Cloud plugin.

My ISP doesn't blocks the incoming traffic, but blocks the traffic if it not requested from my local IP. If my local IP request a service, for example Netflix, ok, but the problem is when the traffic is requested from outside and I need to work with the Octoprint, as a server. Do you think a plugin will solve this problem? Thanks

I believe so. your octoprint server communicates from inside the local network to the astroprint cloud on the internet as if it was browsing the internet and you connect to astroprint, and their servers create the connection between the two.