Problem with probe calibration

What is the problem?

This problem started after I installed the latest version 1.9.3 for the Mac.
After running PROBE_CALIBRATE (I have BLTouch on an Ender printhead) and conducting the paper tests, entering ACCEPT, the nozzle zeroes at about 2 mm above the print bed.

What did you already try to solve it?

in Printer.cfg, z_offset has been commented out by the PROBE_CALIBRATE procedure. I tried putting it back in, but it had no effect, the procedure must have changed something else. Also, the M- commands I'm used to using to do a Z-axis calibration no longer work.
How can I get my Z-axis to behave?

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
Yes (39.3 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

This started life as a base-model Creality printer. I have replaced the bourdon-tube printhead with an Ender direct-feed printhead which has been performing fine for many months. It's only after one of the recent upgrades where they remove many of the "M-commands" that I began to have trouble, usually a print failing because of a g1 to a negative Z coordinate.

This is Klipper stuff. You should go here: