Problem with update a plug-in

I tried to update a plugin called "PrintTimeGenius" from version 2.2.7 to 2.2.8, it ends up with "The update finished successfully and the server will now be restarted." but then it ask me all the time to update. It looks like it haven't updated.

I have tried to uninstall from plugin manager, but after a reboot, it's still there. It hasn't been uninstalled/removed.

Can I some how force an uninstall? Or does anyone know how to fix this?

Going to need a systeminfo bundle. (187.1 KB)
Sorry. The file is included now.

2021-05-15 21:53:14,675 > Cleaning up plugin PrintTimeGenius...
2021-05-15 21:56:25,885   /home/pi/oprint/bin/python3 -m pip --disable-pip-version-check uninstall --yes -ctoPrint-PrintTimeGenius
2021-05-15 21:56:27,923 ! 
2021-05-15 21:56:27,923 ! Usage:
2021-05-15 21:56:27,923 ! /home/pi/oprint/bin/python3 -m pip uninstall [options] <package> ...
2021-05-15 21:56:27,924 ! /home/pi/oprint/bin/python3 -m pip uninstall [options] -r <requirements file> ...
2021-05-15 21:56:27,924 ! 
2021-05-15 21:56:27,924 ! no such option: -c

Well that's interesting. Try removing it manually via:

source ~/oprint/bin/activate
/home/pi/oprint/bin/python3 -m pip --disable-pip-version-check uninstall Print-PrintTimeGenius

Curious if you had another question based on the title of your post? If you're trying to keep the terminal filters checked between connections to OctoPrint, my Active Filters Extended plugin can handle that for you.

Oh sorry, didn’t notice that my browser kept an old post I had where I asked that in my subject.

Changed to a more matching subject now.

Once again, sorry

This is interesting. When I followed your instructions, I get an message saying "WARNING: Skipping Print-PrintTimeGenius as it is not installed." But when I look in the webui plugin manager, it still shows as enabled and installed. I have rebooted the Raspberry Pi, I have tried another browser, just to see so that't the webui isn't cached. you can see 2 screenshots bellow.

I have also taken a screen shot of the popup I get for updating the plugin. The popup is there after I ran "your" command and I rebooted the pi
Screenshot 2021-05-16 at 03.37.07

Oh whoops that might need to be OctoPrint-PrintTimeGenius.

/home/pi/oprint/bin/python3 -m pip freeze | grep -i genius should show the right name if installed.

yes, Now it's uninstalled and I don't get the message to update any more.

Thank you so much, you made me soooooooo happy :slight_smile:

1 Like

Now when I get popup to upgrade a plugin I get another error message that I don't know how to solve, any idea how to solve it?

Installing collected packages: Slicer-Thumbnails
ERROR: Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: '/home/pi/oprint/lib/python3.7/site-packages/octoprint_prusaslicerthumbnails/'
Consider using the --user option or check the permissions.
The update did not finish successfully. Please consult octoprint.log and plugin_softwareupdate_console.log for details.

I have attached the log it say, they are in the zip file. (1.5 MB)

I have also uploaded a new system info file (124.5 KB)

This error is probably related to the new pillow dependency in Slicer Thumbnails. Have you tried deleting the plugin and installing from scratch? The error you are getting doesn't seem to be related to the same issue that was reported to me on Discord.