Problem with webcam streaming\images

Camera model

0 : ov5647 [2592x1944] (/base/soc/i2c0mux/i2c@1/ov5647@36)
Modes: 'SGBRG10_CSI2P' : 640x480 [30.00 fps - (0, 0)/0x0 crop]
1296x972 [30.00 fps - (0, 0)/0x0 crop]
1920x1080 [30.00 fps - (0, 0)/0x0 crop]
2592x1944 [30.00 fps - (0, 0)/0x0 crop]

What is the problem?

Webcam streaming and snapshots\timelapse stopped working.

What did you already try to solve it?

Had a previous version of Octoprint\Octopi before the new webcam stack and everything was working fine. Updated to 1.9x\1.0 and it initially worked but stopped. A browser refresh would bring back the web stream but then stop working totally. Reinstalled with ver 1.92\1.0 and again, streaming\images worked fine initially but stopped again after about 1 day. MJPEG stream /webcam/?action=stream states "server error" in separate browser tab and "Webcam stream not loaded" in Octoprint UI. Safe mode states "The webcam server is currently not running" message. Borrowed another camera and ribbon cable to test with fresh Octopi installs and they work fine. So I am not sure if it some intermittent hardware issue with my camera but was working fine before new stack.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (129.2 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint 1.9.2, Octopi 1.0.0