Problems Getting Static IP setup

So, good evening everyone!!

I dont want to bore you all with too many details, but I will add as much information as I can as I go along :slight_smile:

Short version, I have a raspberry pi, with the Octopi client "2019-09-26-octopi-buster-lite-0.17.0.img"
and I am struggling to get the IP Address to be Static on the Raspberry.

I am installing a second raspberry , and following the steps, and it started and worked just fine. I tried to configure the thing for Satic IP and its only ever getting DHCP IP's

Last night around midnight, after installing and reinstalling about 10 times, it finally just started up and I have a static IP for the Cabled and the wireless. On Raspberry Pi # 2

This morning, I woke up, and went to Raspberry #1 which is configured the same way, but its more or less a year older, but has all the updates.

I did: sudo nano /etc/dhcpcd.con (like on the second one)

I copied the information from the 2nd PI, and pasted it into the First Pi.

Sudo reboot.

and I expected it to just work
it does not.
after the reboot, the DHCP ip changed, but they are still Dynamic.

I have NO clue what to do next,

Information from the LOGIN screen

pi@'s password:
Linux mpcnc 4.14.79-v7+ #1159 SMP Sun Nov 4 17:50:20 GMT 2018 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sat Nov 30 16:33:13 2019 from

Access OctoPrint from a web browser on your network by navigating to any of:


https is also available, with a self-signed certificate.

This image comes without a desktop environment installed because it's not
required for running OctoPrint. If you want a desktop environment you can
install it via

sudo /home/pi/scripts/install-desktop

OctoPrint version : 1.3.11
OctoPi version : 0.16.0

(this is identical to the Other Pi I am running, only its on IP &

When I open my dhcpcd.conf"

interface eth0
static ip_address=
#static ip6_address=fd51:42f8:caae:d92e::ff/64
static routers=
static domain_name_servers= fd51:42f8:caae:d92e::1

interface wlan0
static ip_address=
#static ip6_address=fd51:42f8:caae:d92e::ff/64
static routers=
static domain_name_servers= fd51:42f8:caae:d92e::1

I really could use some help!!

Place holder so I can put even more information

I discovered this just now too. When rebooting, the MAC address of the Pi changes.
This seems a quite usful help.

Thanks, but I am not using the "/etc/network/interfaces"

I am using " dhcpcd"

I will look into it, from everything I have read so far , its 2 different kinds of ways of networking.

<<<<<<<<<<<<<< Moron!!!!

I cant believe this, after 3-4 hours of checking and re-checking.

the ip I was trying to set was inside the range of its tables, and something else was already allocated.


soooo Stupid

changed the IP to something else , and BOOM

it works.


We learn the most by our failures - welcome to the club :sunglasses: