Prusa i3 MK3 having trouble connecting with Octoprint


#1

What is the problem?
I am trying to get Octoprint working with Prusa i3 MK3. I have it connected to the printer via USB. I have Octoprint installed on the Raspberry Pi 3 B+. I have installed the latest version of Octoprint as of 6/10/18.

What did you already try to solve it?
I made sure the Ri Port was enabled on my Prusa i3 MK3.

I have tried the Auto Selections for both the Serial Port and baudrate. I have tried manually selecting a few of the different baudrates 250000 and 115200. I have also tried selecting the serial port /dev/ttyACM0 manually.

I have enabled Wait for start on connect.

I have tried rebooting both the OctoPrint server and my Printer.

I have changed to different USB ports on the Raspberry Pi.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

I went ahead and added the log here as well.

serial.log (5.0 KB)

I'm hoping maybe i'm just missing something simple. I'm having a hard time finding detailed info.

Thanks in advance for any assistance!


#2

Sounds like this issue, if I'm guessing correctly.

The speed of the Prusa should be 115200 based upon what's going on. But I've seen people indicate that it works at 250000 as well.


No response between Octoprint connection and Prusa I3 MK3
#3

Lol funny I just found that one as well. It sounds exactly like it. Sadly looks like I might have to wait until 1.3.9 for a fix according to the comments.

I'll try manually setting to those values again. I wonder if there's a temporary workaround.


#4

Communications at those speeds inside a 3D printer is problematic anyway. The steppers (circuits) involved are electromagnetically noisy since they create spiky square waves.

The proper serial cable would have a metallic sheath but only perhaps 5% of the cables out there have that. In lieu of the right cable, you can add ferrite core(s) to either/both ends which seem to help.


#5

So I've determined my problem...…. Probably stupid on my part. So there is a setting on the Prusa i3 MK3 for RPI Port. I turned that on thinking oh of course I have a Raspberry Pi i'll need this...

Well turns out this stops the Printer from connecting via USB. Guess for the port on the motherboard if I wanted to internally add the Raspberry Pi. Well set my Baudrate to 115200 and tried again. Works like a charm.

Long story short.... make sure if you are using the Prusa i3 MK3 and want to use Octoprint over USB. Do not I repeat do not turn on the RPI port setting on the printer.

Hopefully this prevent others from making a stupid mistake.

Thanks for the assistance!


#6

Wow. I was just power-reading a number of threads on the support forum on the Prusa side of things.

This post appears to be the most useful, though. In short, the Prusa seems to need two serial connections to the Raspi and the original Raspbian setup needs to be tweaked to swap the UARTs. Without doing this activity, the "cheap" UART is being used for the wrong purpose [meaning that it won't go much above 9600 baud as a result].