Prusa i3 MK3S+ & MMU2S select wrong filament Tool

What is the problem?

  • Since monthes I try to reproduce that always again happening wrong filament selection on MMU2s. when starting new print MMU2 loads phisically the wrong Filament. In this case Expected Load T2, Physically Loaded T3.
    I am frustrated and could need adviced where I can look at. I hope somebody could give me a hint where to look at.

Startet Print, T2 selected and also Physically T2 on MMU2 Loaded

2021-09-27 22:24:21,436 - octoprint.util.comm - INFO - Changing monitoring state from "Operational" to "Starting"
Serial Log last time it was physically loading T2 with MMU2 correct responce :
2021-09-27 22:26:52,384 - Recv: MMU <= 'T2'
(be aware I had to reslice it, after I saved Log, but up to now I have never seen the case that Gcode is wrong):

Startet Print, T2 selected and Physically T3 on MMU2 Loaded

2021-09-27 23:59:33,776 - octoprint.util.comm - INFO - Changing monitoring state from "Operational" to "Starting"
Serial Log startet a new Printer Job
2021-09-28 00:03:10,709 - Recv: MMU <= 'T3'
(be aware I had to reslice it, after I saved Log, but up to now I have never seen the case that Gcode is wrong):

What did you already try to solve it?

  • Configuration in Octopi 5 Extruder and shared nozzle is configured correctly. (a few Month ago this was configured wrong from me)
  • checked that PINDA and FINDA sensor are switching correctly. Upgraded with externel LED State and it seems to be ok.(I had some issues in earlier time that Filament Sensor pulled down, and MMU2 changed automatically to next Tool Position durig print)
  • To prevent any damaged SD Card on Rpi 4B Remade a complete Image, and step by step configured the Octopi to my need.
  • In rearlier stage I have also tried when Problem apears to run the same Gcodefile directly over SD Card. It was interesting that also in that case it also selected wrong Tool. after Power Off/On Cycle everything was again OK. For my understanding it would mean that it is a MK3S <--> MMU issue.
  • Noticed that since I am using Host instead of IP address to acces Octopi, the commuication lost of wifi has disapeared, and also load of wrong Filament gots less. (is it related to each other I can`t tell, but Blog entry from Nina helped a lot. Thanks...)
  • Noticed that each time I consequently Power OFF/ON Printer and Octopi after Reboot behave was always correct. (In past I didn`t want to spend to much time by analysing the issue, but over time I had to)

Have you tried running in safe mode?

  • Yes I have, but vicious circle type of problem is that each time I restart Octopi in Safe mode, it kind behaves same way the POWER OFF/ ON Cycle. So afterwards everything work again absulutely fine. I can even restart the same print file and after Restart it selects the right tool.

Did running in safe mode solve the problem?

Dont know. I havent run long enough Printer in safe mode. (I decided at the moment to constently run in safe mode, until problem apears again, or not. Keep informed.

Systeminfo Bundle

System Bundle
Octopi LOG

Additional information about your setup

  • OctoPrint 1.6.1
  • Python 3.7.3
  • OctoPi 0.18.0
  • Prusa MK3s+ 3.9.3
  • MMU2s 1.0.6

Turn off spool join on the printer settings and see if it still happens. This sounds like an MMU problem and nothing to do with OctoPrint.

Wow i didn`t realized that this caused that much trouble I had.

  • I noticed that sequenz of changing to next Slot, in some cases, so if I understand correctly the sensor shortly dropped.
  • the other case I noticed was randomly loading an other slot. Up2know approx 12 print Jobs it hasen`t happen.
    Thanks a lot