Prusa l3 vsn 2 Using Home causes extruder to crash into hotbed


#1

Hi Everyone,

This is a warning of a potential problem for Prusa I3 vsn 2 users

I’m a new Octopi user, as of yesterday, and have just installed Octopi 0.15.1 on my Pi 3 and connected it to my working and calibrated Prusa i3 Mk2. I’ve copied a profile from this site for the printer. All seemed well. However clicking on the home button caused the extruder head to hit the hotbed. By the time I turned the printer off the hotbed had been damaged. Luckily it’s outside the main print area. The firmware on the Prusa is Venice 3.1.0. The problem is repeatable.

I’ve not investigated the problem yet. I posted this quickly to warn others. Im going to recalibrate the printer and print the parts for the 2.5 upgrade before trying Octopi again. If anyone has a fix please let me know.

This apart I’m really impressed with the software and look forward to using it.

Regards, squirrox


#2

I don't know the Prusa so I could only give generic advice on this. My first two months of owning my printer, I drilled the (often hot) extruder into my plastic bed, causing damage of course. This was caused by the combination of software added by my printer's manufacturer.

  • Review the Settings -> Printer Profiles -> Prusa -> edit area and look at all the settings, especially those for Z axis, its related Invert Control checkbox as well as the build volume values stored
  • Review the Terminal output when you enter M115 to get a report from your firmware
Recv: echo:Home offset (mm)
Recv: echo:  M206 X0.00 Y0.00 Z-15.00

On my Robo C2, the bed moves up and down so I have to select the Invert Control checkbox for the Z axis setting.

  • Check the Z end-stop switch status by running an M119 and comparing it with reality
  • Always know what mode that your motors are in: absolute or relative.
  • Review the absence of Gcode scripts in your OctoPrint -> Settings -> GCODE Scripts area. You might need to explicitly home the X/Y/Z, set the expected mode, zero out the movement audit with a G92.

In fact, upon the very first time of running OctoPrint, it doesn't know where your X/Y/Z are so it's necessary to perform a homing command.

When I press the Home-Z button on the Control tab, this is what I see was sent in the Terminal:

G91          # Relative mode
G28 Z0       # Home the Z at 0mm
Recv: X:0.00 Y:0.00 Z:145.00 E:0.00 Count X: 0 Y:0 Z:116000
Recv: ok
G90          # Absolute mode

If this behavior drills your hotend into the bed, then you should review your Z-Offset setting in your EEPROM to make sure that it's correct.


#3

Thanks for the information. I’ll do some tests, I was sucked in by some of the setup videos on YouTube which lead me down the garden path somewhat. It’s clear now that there is more to do than install the software and hook things up.

What you say is entirely logical. Thanks again!