Prusa Mini Connectivity?

What is the problem?
I've been struggling off and on for about a week trying to get Octoprint to recognize my mini. I know the Mini is technically unsupported but from this post ( it appears others have been successful. Below are my setup details and the Octoprint log.

What did you already try to solve it?
Besides the /dev/tty* options I also have /dev/ttyAMA0 /dev/printk and /dev/ttyS0 . In order for the test to get past "permission denied" on /dev/ttyS0 I had to chmod 777 but I know that's not a good idea. I have tried reinstalling Octoprint and different USB cables (micro to type A)

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)
2020-03-17 18:47:45,470 - Changing monitoring state from "Offline" to "Detecting serial port"
2020-03-17 18:47:45,497 - Serial port list: [u'/dev/ttyS0']
2020-03-17 18:47:45,497 - Connecting to: /dev/ttyS0
2020-03-17 18:47:45,504 - Changing monitoring state from "Detecting serial port" to "Error: Connection error, see Terminal tab"
2020-03-17 18:47:45,507 - Unexpected error while connecting to serial port: AUTO SerialException: '[Errno 13] could not open port /dev/ttyS0: [Errno 13] Permission denied: '/dev/ttyS0'' @ (hook default)
2020-03-17 18:48:35,005 - Changing monitoring state from "Offline" to "Detecting serial port"
2020-03-17 18:48:35,056 - Serial port list: [u'/dev/ttyS0']
2020-03-17 18:48:35,056 - Connecting to: /dev/ttyS0
2020-03-17 18:48:35,058 - Changing monitoring state from "Detecting serial port" to "Opening serial port"
2020-03-17 18:48:35,061 - Connected to: Serial<id=0xaa794590, open=True>(port='/dev/ttyS0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
2020-03-17 18:48:35,062 - Starting baud rate detection...
2020-03-17 18:48:35,063 - Changing monitoring state from "Opening serial port" to "Detecting baudrate"
2020-03-17 18:48:36,067 - Trying baudrate: 115200
2020-03-17 18:48:36,078 - Send: N0 M110 N0*125

........ tries all other baud rates unsuccessfully

2020-03-17 18:49:20,293 - Changing monitoring state from "Detecting baudrate" to "Error: No more baudrates to test, and no suitable baudrate found."
2020-03-17 18:49:20,313 - Changing monitoring state from "Error: No more baudrates to test, and no suitable baudrate found." to "Offline (Error: No more baudrates to test, and no suitable baudrate found.)"
2020-03-17 18:49:20,343 - Connection closed, closing down monitor

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)
Raspberry Pi 4
Octoprint v 1.4.0
Prusa Mini v 4.0.3
Serial Connection>General>SerialPort: Auto
Serial Connection>General>Baudrate: Auto
Serial Connection>General>Autoconnect: unselected
Serial Connection>General>Additional Serial Ports: empty
Serial Connection>General>AdditionalBaudrates: empty
Serial Connection>General>request exclusive access: unselected
Serial Connection>General>apply parity double open: always

I am struggling with the same issue, coming from a Raspberry Pi 3B+. Can not get the serial connection to work.

I was recently able to get it working on my Mini by upgrading it the recently release Mini firmware 4.0.5

I have 4.0.5 but still have the problem. Lacyclone, did you use "auto" or some specific settings?

I believe there's a potential issue with auto (port select) that Gina posted about.

@MStylesMS I am using /dev/ttyACM0 and baud rate 115200 with an out of the box Octopi installation on my pi v4. Once I installed the new Mini firmware, the connection worked great with the port and baud rate I listed. Good luck!

@iacyclone those setting worked perfectly for me too. Thanks!f

Great to hear