Prusa MK2.5S MMU2S restarts when print initiated while OctoPi is connected

I am experiencing a similar problem with my I3mk3s MMU2s recently.

Printing from SD works (starting from the printer's panel)
Printing the identical gcode from Octoprint, the job starts, bed levelling runs through but after that the printer resets before loading the filament. When I preload the according filament to the nozzle before starting the print from Octoprint, job runs correctly.

This behaviour is new, everything worked fine before. Unfortunately I (yes, I know, stupid!) I can not circle this is completely as I did overlapping changes and upgrades in Printer Firmaware and Octoprint.

Prusa I3mk3s (upgraded from mk3) with MMU 2s (upgraded from MMU2)
Latest Firmware (3.8.0 and 1.0.6)
Octoprint 1.3.12rc3 on a RPi3

I already deactivated most Plugins in Octoprint, my planned next steps is to downgrade the Firmware of the Prusa and the MMU. Any other suggested steps?

Thanks

1 Like

JoKey - I have basically the exact setup you do, mk3s, mmu2s, and running Octoprint from RPi3. . . I spent close to a month trying to dial the thing in, with the restart after calibration preventing any prints from starting at all. At this point, after trying sooo many things, it is hard to nail down how I got it working, but I'll give it a shot in the hopes that it may help you or someone else who is close to throwing their MMU2 against a wall.

  1. I went through the individual filament length calibration for all 5 by going into the "secret" menu. There is a great vid on youtube about tips and tricks with the mmu2 that runs through this. The Prusa handbook mentions that this is unnecessary, but I think it helps a TON. I'm not sure why, but I feel like this step is what cleared up the restarts.
  2. I checked my FINDA at the selector, and I feel like if it is down too far, it can cause false positives or other issues, so I pulled it about 2 or three threads up after trapping filament, then another two threads or so. I think it's better to err on it being too high than too low.
  3. I double checked the extruder gear alignment, and also that the I/R sensor was showing filament. I had tried disabling that sensor to see if it helped, but it ended up causing more problems. I think the tension screw holding the idler door needs to be on the tighter side. I was afraid at first to go past "flush" with the screw head, but now I have it recessed a little.

I am running the latest firmware and software on the Prusa, on Octo, the MMU2s itself (don't forget that!) as well as making sure Prusa Slicer has the mk3S MMU2S showing as the printer. . . those s's are important! Hope you get printing again, good luck!

Hi @Madpauly!

So do you have a MMU2 or a MMU2S? For the MMU2S hat the IR sensor at the extruder, there is no need for a filament length calibration at all. I erased the values here and never had a problem. So the correct IR sensor adjustment is important.

To your second point: there is a modified selector at Thingiverse that drags down the steel ball at the FINDA with a magnet.

As a hint: The MK3S should have the correct heatbreak the one with the smaller diameter), but one never knows...

Thanks Ewald,

I have the MMU2S, so who knows, maybe while I was messing with filament calibration I bumped the I/R the right way to have it start working! It is true that the sensors are so important; correct adjustment helps loading and unloading issues too. I'll check out that selector mod - that should help with filament sensing up top.

I have an exciting update!

I was going through all my wiring again since my MMU2S upgrade. The MK2.5S has two plugs from the power supply, but the MMU2S board needs one too so they include a power splitter. The directions for the upgrade say:

Follow the cables from the PSU and unplug one connector from the RAMBo board (both are the same).

But the image shows arrows unplugging the power cable which happens to be the heat bed one. Naturally I followed that photo.

Since my reboot issue is directly related to when gcode commands turn on the heat bed (determined by @foosel), I decided to try swapping the splitter to the other (hot end) power port. This has completely solved my issue and I can now print with OctoPrint!

I guess there's some power situation with the heat bed when a bit of power is siphoned off for the MMU2S board. Plugging in the splitter to the hot end port does not appear to cause the same reboot issue.

@Ewald_Ikemann if you have a moment some day, would you mind checking if your MMU2S power splitter is plugged into the hot end or heat bed port? If it's in the hot end side, maybe you could swap it to the heat bed port for a try. That way we can see if it reproduces my original problem for you and we will be able to report this to Prusa support for them modify the upgrade directions. I don't feel comfortable saying for sure that they [Prusa] should explicitly recommend using the hot end side for the splitter without first having some corroborating evidence... and obviously I don't have another MK2.5S MMU2S or know anybody else with this exact setup so it might be nice to give it a whirl for the community.

I'm going to try downgrading to previous firmware temporarily to see if this was also what was causing my slightly different issue. Also I recognize that others have started using this thread as a rally point for their similar issues with MK3 so feel free to continue your discussion despite it being a different technical problem considering you don't need to use the splitter on that printer.

My deepest appreciation to everyone who participated in this troubleshooting adventure, I am so excited to be up and running again!

3 Likes

The same is for the MK3S Version. Tried it for 1 1/2 weeks to find your post and try it on the new board. Same result - it works now!!

1 Like

So after installing the new octoprint 1.3.12 I got the same restart failures again. In the moment it should start to print... the printer resets it self and stops completly. Can anyone confirm this failure?

Setup:
Raspi Pi 4, OctoPrint 1.3.12 - OctoPi 0.17.0
Prusa MK3S (3.8.0) + MMU2S (1.0.6)