Prusa MK3S MMU2 will not Connect to Octoprint

What is the problem?

I try to connect via RPI3 and USB Port.
The connection Works fine but one Day, I did no changes on the Settings off the Printer and Octoprint and this Error comes.

Changing monitoring state from "Offline" to "Opening serial connection"
Connecting to port /dev/ttyACM0, baudrate 115200
Changing monitoring state from "Opening serial connection" to "Connecting"
Connected to: Serial<id=0x6b665f30, open=True>(port='/dev/ttyACM0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=60.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Send: N0 M110 N0*125
Recv: start
Send: N0 M110 N0*125
Recv: ;S
Recv: ;S
Recv: ;S
Recv: ;S
Recv: ;S
Recv: SN update failed
Recv: echo: 4.0.2-2528
Recv: echo: Last Updated: Aug  1 2022 16:46:42 | Author: (none, default config)
Recv: Compiled: Aug  1 2022
Recv: echo: Free Memory: 1836  PlannerBufferBytes: 1760
Recv: echo:Stored settings retrieved
Recv: echo:Steps per unit:
Recv: echo:  M92 X100.00 Y100.00 Z400.00 E415.00
Recv: echo:UStep resolution:
Recv: echo: M350 X16 Y16 Z16 E16
Recv: echo:Maximum feedrates - normal (mm/s):
Recv: echo:  M203 X200.00 Y200.00 Z12.00 E120.00
Recv: echo:Maximum feedrates - stealth (mm/s):
Recv: echo:  M203 X100.00 Y100.00 Z12.00 E120.00
Recv: echo:Maximum acceleration - normal (mm/s2):
Recv: echo:  M201 X1000 Y1000 Z200 E5000
Recv: echo:Maximum acceleration - stealth (mm/s2):
Recv: echo:  M201 X960 Y960 Z200 E5000
Recv: echo:Acceleration: P=print, R=retract, T=travel
Recv: echo:  M204 P1250.00 R1250.00 T1250.00
Recv: echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s),  Z=maximum Z jerk (mm/s),  E=maximum E jerk (mm/s)
Recv: echo:  M205 S0.00 T0.00 B0.00 X10.00 Y10.00 Z0.40 E4.50
Recv: echo:Home offset (mm):
Recv: echo:  M206 X0.00 Y0.00 Z0.00
Recv: echo:PID settings:
Recv: echo:   M301 P16.13 I1.16 D56.23
Recv: echo:PID heatbed settings:
Recv: echo:   M304 P126.13 I4.30 D924.76
Recv: echo:Retract: S=Length (mm) F:Speed (mm/m) Z: ZLift (mm)
Recv: echo:   M207 S3.00 F2700.00 Z0.00
Recv: echo:Recover: S=Extra length (mm) F:Speed (mm/m)
Recv: echo:   M208 S0.00 F480.00
Recv: echo:Auto-Retract: S=0 to disable, 1 to interpret extrude-only moves as retracts or recoveries
Recv: echo:   M209 S0
Recv: echo:Filament settings: Disabled
Recv: adc_init
Recv: Extruder fan type: NOCTUA
Recv: CrashDetect DISABLED
Recv: FSensor ENABLED (sensor board revision: 0.3 or older)
Recv: Sending 0xFF
Recv: echo:SD card ok
Recv: LCD status changed
Recv: // action:dump_available
Recv: MMU2S => MK32S 'V:402'
Recv: MMU2S => MK32S 'BN:380'
Recv: MMU version valid
There was a timeout while trying to connect to the printer
Changing monitoring state from "Connecting" to "Offline"
Connection closed, closing down monitor

I try to connect via RPI3 and USB Port.
I did no changes on the Settings off the Printer and The Octoprint and this Error comes.

What did you already try to solve it?

RPI Port is off.
Active second Serial Port on Printer.
Reinstall Octopi
Flash the Printer FW new.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in (27.2 KB)
... no bundle, no support!)


Additional information about your setup

OctoPrint version 1.8.1, OctoPi version 0.18, Prusa MK3S MMU2, TZB FW 4.0.2 compiled by my own, Firefox, Windows 10, ... as much data as possible


Hello @rg373 !

Where did you get this firmware from?
The recent one from Prusa if from 15th of June.

As for this, you are running TZB firmware, yes?
If it is so, you should mention this in your post.

Anyhow, the date of 4.0.2-2528 is 14th of February.
Did you compile it on your own?

According to the terminal snippet, there is a connection, but it runs into a dead end with no response to OctoPrint


thanks i changed it

According to this, you may install the genuine firmware to check if it works.
If yes, you may check your version for errors.

With the original FW it works but only if i chose Baudrate AUTO.


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.