Prusa MK3S resets a few minutes into printing

What is the problem?

Printer resets a few minutes into a print. Will reset if printing from SD card but connected to OctoPrint. Does NOT reset if printing from SD card and disconnected from OctoPrint.

What did you already try to solve it?

Flashed firmware on printer (Bondtech firmware). Using most current OctoPrint build. Flashed new OctoPrint to Rasp Pi.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Uploaded. (125.8 KB) (581.1 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I am using a Bondtech Extruder. Most current firmware flashed to printer.

Hello @Dave_Smith1 !

This looks weird:

2023-10-31 20:40:05,712 - Send: N2310 G1 X138.29 Y138.421 E.08496*93
2023-10-31 20:40:05,717 - Recv: INT4
2023-10-31 20:40:05,861 - Recv: T:209.7 /0.0 B:60.2 /0.0 T0:209.7 /0.0 @:28 B@:0 P:44.1 A:35.7
2023-10-31 20:40:06,144 - Recv: UVLO - end 411
2023-10-31 20:40:08,155 - Recv: start
2023-10-31 20:40:08,156 - Printer sent 'start' while printing. External reset? Aborting job since printer lost state.
2023-10-31 20:40:08,167 - Send: N0 M110 N0*125
2023-10-31 20:40:08,170 - Changing monitoring state from "Printing" to "Cancelling"
2023-10-31 20:40:08,335 - Recv: echo: 3.13.1-7615
2023-10-31 20:40:08,335 - Recv: SpoolJoin is Off
2023-10-31 20:40:08,336 - Recv: echo: Last Updated: 2023-09-26 18:24:21 | Author: (none, default config)
2023-10-31 20:40:08,336 - Recv: echo: Free Memory: 2523  PlannerBufferBytes: 1760
2023-10-31 20:40:08,336 - Recv: echo:Stored settings retrieved
2023-10-31 20:40:08,337 - Recv: adc_init
2023-10-31 20:40:09,310 - Recv: Hotend fan type: NOCTUA
2023-10-31 20:40:09,312 - Communication timeout while printing, trying to trigger response from printer. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves.
2023-10-31 20:40:09,313 - Recv: CrashDetect ENABLED!
2023-10-31 20:40:09,321 - Send: N0 M110 N0*125
2023-10-31 20:40:09,683 - Recv: Sending 0xFF
2023-10-31 20:40:09,695 - Recv: echo:SD card ok

Does it appear to happen on a certain gcode file or all?

Can you attach the gcode file you tried to print to your next post? You can compress it.

BTW: The files you shared in the are included in the systeminfo bundle.

Thank you so much. Some additional things I've done is revert the printer firmware a couple versions back to see if it helps; it doesn't. If I even have the printer connected and print from an SD card, it quits mid print. I have to completely remove the USB cable to print from SD card safely. This is the gcode I used.

Thank you again. I'm at my wit's end.

The gcode file seems to be ok.

It appears that the printer performs a restart mid print.

The why and how is up to Prusa.

Maybe a faulty PSU :man_shrugging:

Someone on a different forum said it could be my cable not able to handle the baud rate, but I think it’s far-fetched. I’ll swap it out as a troubleshooting step anyway.

I’ve reached out to Bondtech, who wrote the printer firmware. I think it has to do with Prusa’s addition of an emergency stop hard coded into the firmware. I’ll also try to find out when they added that feature and try a firmware before that point.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.