Prusa MK3s w/MMU Enqueing to front M600

What is the problem?

almost any print sent with octoprint (1.7.2) results in the same issue of after a bed probe the extruder parks and begins an m600 filament change. It "unloads" then loads a random position on the MMU, then unloads that and loads the proper position and asks if it was loaded correctly. It then re probes the bed and begins printing.

What did you already try to solve it?

I have tried turning off all 3rd party plig ins, running in safe mode, changed the filament sensor and recalibrated, printing from SD card, and a fresh install of octoprint. Problem does not replicate when printing from SD.

Have you tried running in safe mode?

Yes, no improvement.

Did running in safe mode solve the problem?

no

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint-systeminfo-20220113032532.zip (41.2 KB)

Additional information about your setup

Octoprint 1.7.2, octoprint 18, browser chrome 97. Board Raspberry pi 4b, official power supply, no power issues or throttling. Sheilded usb cable.

Latest prusa firmware of 3.10 and latest MMU firmware, re flashed last week to be sure. Using prusaslicer official build 2.4.

Adding a snippet of the terminal log when this happensProcessing: TerminalLog.txt...

Of course as soon as I enable serial logging it stops acting up.... Leaving it on in case it happens again

Snagged it happening, hopefully its in here somewhere. I'll see if I can replicate it in safe mode tomorrow.

serial (1).log (894.5 KB)
octoprint (1).log (414.1 KB)

octoprint-systeminfo-20220113042007.zip (193.5 KB)

EDIT: got it to do it in safe mode with the very next print, info below
octoprint-systeminfo-20220113043920.zip (185.4 KB)