Prusa mmu v2 not working


#1

What is the problem? Cannot print with mmu v2 in single mode

What did you already try to solve it? tried many things. tried altering the g code to let it know what filament i want to use. no fix

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

<OctoPrint 1.3.9 running on OctoPi 0.14.0>
Prusa mk3 mmuv2 latest firmware


#2

Hi @penfold81,

I'm still waiting for my MMU 2.0.
I remembered that one plugin made problems with the single mode MMU 1.0 too. Can't remember what. I'll investigate.
Have you tried the save mode with OctoPrint?


#3

Same problem.

Hopefully there's a solution soon.


#4

Could both of you please share some logs so the people capable of potentially fixing anything in OctoPrint (read: me) are at least able to understand what is not working? "Cannot print" isn't really helpful. Thanks.


#5

I will try another print when Iā€™m home and will document what happens

Thanks

Dave


#6

Even sans logs it'd be helpful if you could describe what the problem is. I avoid using single mode because it wants to prompt for a filament; instead I use MMU2 mode and just select one filament.


#7

Hello there,

I am running the MK# with the MMU V2 and I experience the same issue or near same issue.

ISSUE: Octopi is not aware of an Intervention step required by the user to confirm the loaded filament on the RamBo LCD.

MY SETUP

  • OctoPrint 1.3.10 running on OctoPi 0.15.1

  • Slic3r PE connected via KEY to Octopi

  • Slic3r PE configuration has 1 extruders with support ticked for Single Extruder Multi Material Mode.

  • OctoPi set up of printer is AUTO, AUTO, 5 Extruders, 1 shared nozzle

Trail on log

Changing monitoring state from "Offline" to "Detecting serial port"
Serial port list: ['/dev/ttyACM0']
Connecting to: /dev/ttyACM0
Changing monitoring state from "Detecting serial port" to "Opening serial port"
Connected to: Serial<id=0x723537f0, open=True>(port='/dev/ttyACM0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Starting baud rate detection...
Changing monitoring state from "Opening serial port" to "Detecting baudrate"
Trying baudrate: 115200
Send: N0 M110 N0*125
Recv: start
Changing monitoring state from "Detecting baudrate" to "Operational"
Send: N0 M110 N0*125
Recv: echo: 3.5.0-1749
Recv: echo: Last Updated: Nov 22 2018 23:35:16 | Author: (none, default config)
Recv: Compiled: Nov 22 2018
Recv: echo: Free Memory: 2038  PlannerBufferBytes: 1392
Recv: echo:Stored settings retrieved
Recv: adc_init
Recv: CrashDetect ENABLED!
Recv: PAT9125_RES_X=0
Recv: PAT9125_RES_Y=240
Recv: PAT9125_init:1
Recv: PAT9125_RES_X=0
Recv: PAT9125_RES_Y=240
Recv: PAT9125_init:1
Recv: FSensor ENABLED
Recv: echo:SD card ok
Recv: Error:No Line Number with checksum, Last Line: 0
Recv: Resend: 1
Send: N1 M115*39
Recv: ok
Recv: fsensor_autoload_check_start - autoload ENABLED
Recv: 
Send: N2 M21*18
Recv: FIRMWARE_NAME:Prusa-Firmware 3.5.0 based on Marlin FIRMWARE_URL:https://github.com/prusa3d/Prusa-Firmware PROTOCOL_VERSION:1.0 MACHINE_TYPE:Prusa i3 MK3 EXTRUDER_COUNT:1 UUID:00000000-0000-0000-0000-000000000000
Recv: ok
Recv: echo:SD card ok
Send: M20
Recv: ok
Recv: Begin file list
Recv: G18E27~1.GCO 2632986
Recv: G25CAC~1.GCO 8763285
Recv: End file list
Recv: ok
Send: M105
Recv: ok T:107.1 /0.0 B:70.6 /0.0 T0:107.1 /0.0 @:0 B@:0 P:42.4 A:38.4
Send: M105
Recv: ok T:104.8 /0.0 B:70.2 /0.0 T0:104.8 /0.0 @:0 B@:0 P:42.2 A:38.2
Send: M105
Recv: ok T:102.6 /0.0 B:69.8 /0.0 T0:102.6 /0.0 @:0 B@:0 P:41.9 A:38.5
Send: M105
Recv: ok T:100.5 /0.0 B:69.4 /0.0 T0:100.5 /0.0 @:0 B@:0 P:41.8 A:38.0
Recv: MMU version valid
Recv: MMU - ENABLED
Send: M105
Recv: ok T:98.5 /0.0 B:69.0 /0.0 T0:98.5 /0.0 @:0 B@:0 P:41.7 A:38.1
Changing monitoring state from "Operational" to "Printing"
Send: N0 M110 N0*125
Recv: ok
Send: N1 M73 P0 R11*36
Recv: NORMAL MODE: Percent done: 0; print time remaining in mins: 11
Recv: SILENT MODE: Percent done: 255; print time remaining in mins: -1
Recv: ok
Send: N2 M73 Q0 S11*39
Recv: NORMAL MODE: Percent done: 0; print time remaining in mins: 11
Recv: SILENT MODE: Percent done: 0; print time remaining in mins: 11
Recv: ok
Send: N3 M201 X1000 Y1000 Z1000 E5000*57
Recv: ok
Send: N4 M203 X200 Y200 Z12 E120*8
Recv: ok
Send: N5 M204 P1250 R1250 T1250*80
Recv: ok
Send: N6 M205 X8.00 Y8.00 Z0.40 E1.50*60
Recv: ok
Send: N7 M205 S0 T0*36
Recv: ok
Send: N8 M107*45
Recv: ok
Send: N9 M107*44
Recv: ok
Send: N10 M115 U3.5.0*84
Recv: ok
Send: N11 M83*40
Recv: ok
Send: N12 M104 S215*80
Recv: ok
Send: N13 M140 S60*97
Recv: ok
Send: Tx
Send: N14 M190 S60*107
Recv: echo:busy: paused for user
Printer seems to support the busy protocol, will adjust timeouts and set busy interval accordingly
Recv: echo:busy: paused for user
Recv: echo:busy: paused for user
Recv: echo:busy: paused for user
Recv: echo:busy: paused for user
Recv: echo:busy: paused for user
Recv: echo:busy: paused for user

Result is that you have to press a button to say what filament lane number is to be used, rather than defaulting to a specific pre-configured selection.

Unless of course I am not doing something correct here, but this is the problem I have and I hope it reflects the above less detailed explanations of the experience.


#8

Hello @Brebinator,

this is the setting of Slic3r. This already was the behaviour of MMU V1.

For I sometimes forget to select the filament, I added a short beep to the start GCODE of the single filament printer profile.

You also could try to assign a color to the model as you do in MMU-mode.


#9

Thank you I will have a look at that option.