Prusa slicer thumbs disappear after page refresh

What is the problem?

prusa slicer thumbnails going missing after firefox page refresh

What did you already try to solve it?

don#t know what to do

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
I run the latest Version of octoprint (1.9.1) and octopie (1.0) (51.4 KB)
, set up correctly on a raspberry pi 4b 8GB, alongside with pimorony hyperpixel 4 sq drivers and the last version of octodash installed

when I first upload a file from prusa slicer the thumnails show up correctly, after refreshing the page in firefox / edge they are gone. If I try to say "load image again", nothing changes. If I try to "open image in new tab" it shows the following location in the url:
when I try to find the image via ssh (putty), it tells me, that the directories don´t exist. thge command ls does not show the folders.
After the print, the thumnails in print job history do not show up.

regards, Christoph

Have you tried re-installing the plugin?

O.K., this seemed to do the trick - but not out of tghe box, and not enirely - I tried twice, before I reinstalled the second time I created the "missing" directories vie SSH (putty). Now the thumbs are there, even after refreshing the page.
But now the thumbnail is missing on the octodash screen.
As it seems slicer Thumbs and Octodash are canibalizing themselves...

thanks for the help so far,


The issue that you were experiencing is because you had the option to store the images in the uploads folder. That causes the URL for the images to be from the download endpoint instead of the built-in plugin's endpoint. It's a very rare case you would want to use that option at all.

1 Like

O.K. thanx, I already changed the setting, but I have to wait until the current print is finished to try out, if that will work. For now the images are showingh inside octoprint at least, for octodash I have - as I said - to wait. Do You - by any chance - know, why - even with my previous changes - no images show up in printjob history? Will they - after changing to the proposed setting?

there's a good chance that printjobhistory plugin will work once that change is made, because the image files will be where that plugin thinks they are. The save images in uploads folder was something added recently for someone else's request.

1 Like

With your proposed setting all is O.K. now for the standard views, the images stay even on refresh.
Print Job History however is still missing these images and just showing a placeholder / Broken link placeholder icons.

That I can't help with and you'd have to reach out to that plugin author. I suspect it might take a snapshot on completion or something and stores it's own copy maybe and if it wasn't accessible before those no image ones are used instead maybe.

1 Like

All good, I will reach out to print history`s maker, to get help there. Anyway, I thank you for continuos caring!

I view into the git gives a workaround:


O.K. Thanks again! I have to wait for current print to finish, then I´ll give that one a try!

1 Like

Just to let you know - it works - thx


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.