Prusaslicer "Object doesn't fit print volume"

What is the problem?

I use Prusaslicer 2.3 with Octoprint Version 1.5.3. Most of the time I get this message after uploading a gcode file and starting to print:

Object doesn't fit print volume
Object in xxx.gcode exceeds the print volume of the currently selected printer profile, be careful when printing this.

Object exceeds print volume in depth.
Object's bounding box: (0.00, -3.00, 0.00) × (177.38, 187.37, 111.00)
Print volume: (0.00, 0.00, 0.00) × (250.00, 210.00, 210.00)
You can disable this check via Settings > Features > "Enable model size detection [...]"

What did you already try to solve it?

I assume it has to do with the starting gcode produced by Prusaslicer containing this line:
G1 Y-3.0 F1000.0 ; go outside print area
However this is needed for the initial purge of filament prior to the start of the printing.

I click print again and it starts printing. I did not want to turn off the warning because it might save me from attempting a problem print.

Additional information about your setup

OctoPrint Version 1.5.3, Version 0.17.0, running on Raspberry Pi 4 Model B Rev 1.1

Setup a custom bounding box in the settings, that includes the negative section.

Expanding on Charlie's post. IIRC by default PrusaSlicer does a prime line in negative X. If you can't/don't want to go negative, look in the PrusaSlicer Custom GCode for your printer an move the prime line.

Thanks Charlie_Powell,

That was one of those settings easily overlooked since the parameters don't appear until you check the box on the screen. I will set it and see if the alert goes away the next time I print. I'm sure it will work.

Dale

The OctoPrint Printer Profile needs to be filled out correctly. First, you define the print volume which should be the maximum printable dimensions. Second, you can (optionally) define a Custom bounding box which, as the text on the page explains, is a larger volume that specifies the minimum and maximum values that might be present in the gcode.

This bounding box allows for things like nozzle cleaning, auto bed leveling probe locations, etc.

I believe the solution to your problem is to check the Custom bounding box and fill in the correct values. At the very least, Y should go from -3 to 210.

I tried to set a custom bounding box with -3 for the Y minimum. However, when I click on "Confirm" the circle icon keeps spinning and never comes back. I've reported the problem in the GitHub Octoprint forum.