PSU Control fails after update

What is the problem?

I updated Octoprint from 1.5.0 to 1.6.1. The PSU Control no longer turns on/off my printer.

What did you already try to solve it?

I installed PSU Control - RPI.GPIO

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (40.5 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I did not set up the PSU Control. A friend did it for me and he is not available. I really have no clue as to what it all means. I believe that I am using pin 40.

With the recent edition of PSU control, pin addressing changed to only support GPIO pin addressing schema. you frind probably used another scheme, which now needs to be translated to GPIO schema

pin 40 translates to GPIO 21, try that in configuration -> under "wrench" -> scroll down to "PSU Control"

try updating "on/off gpio pin" to 21 ?

Thank you! That seems to be working now! I changed the PSU Control Value to 21 but left the RPI.GPIO Switching value at 40 (which I had tried earlier). Does that all sound OK?

Except for very specific cases you shouldn't need the PSU Control - RPi.GPIO sub-plugin. Just remove it.

I removed it and PSU Control still works fine. Thanks!