PSU-Plugin shuting down system during boot sequence

What is the problem?

I have a Ender 3 Pro with a Pi4 and actual, fresh installed Octoprint.
Then i use PSU-Control with Shelly-Sub-Addon to control a Shelly plug that power off the hole stuff if the printer is in idle for 20 minutes.
This works one time, and after this 1x successfully event, every time i boot the system by powering it up with the shelly-app, the system is booting up, and at one point the psu-control thinks the timeout is reached and switch the shelly plug off again in the boot sequence.
The plug powers the pi and the printer at the same time because the pi gets his power fom the printer power supply. I dont want the pi run the hole time.
and this constelation worked for some month. for me it seems that a update make some change and the plugin cant get the correct state during boot.
I know that this is not a "normal" way to power a system down, but it works.

What did you already try to solve it?

power the system without a shelly-plug so the system starts normaly. then i use "shut down" from the octoprint menu, power all down, install the shelly plug again, and then the system starts normaly. but after 1x PSU-activation, i need to repeat this steps.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (14.5 KB)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

browser.user_agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/99.0.4844.82 Safari/537.36
connectivity.connection_check :
connectivity.connection_ok : true
connectivity.enabled : true : true
connectivity.resolution_check :
connectivity.resolution_ok : true
env.hardware.cores : 4
env.hardware.freq : 1500
env.hardware.ram : 3971153920
env.os.bits : 32 : linux
env.os.platform : linux
env.plugins.pi_support.model : Raspberry Pi 4 Model B Rev 1.4
env.plugins.pi_support.octopi_version : 0.18.0
env.plugins.pi_support.octopiuptodate_build : 0.18.0-1.7.3-20220120112925
env.plugins.pi_support.throttle_state : 0x0
env.python.pip : 20.3.3
env.python.version : 3.7.3
env.python.virtualenv : true
octoprint.safe_mode : false
octoprint.version : 1.7.3
printer.firmware : Marlin (Jun 9 2021 00:18:40)
systeminfo.generator : systemapi

I have a smart plug for my printer but I leave the RPi running all the time. It doesn't use much power and I find it useful to have around even when I'm not printing something.

The most obvious advantage to this approach is that I can use an OctoPrint plugin to turn the printer on and off.

tagging @kantlivelong

Don't do this.

why? worked for over 9 month perfectly. Dont want and need a PI running the hole time

Because switching off the Pi can cause issues with the file structure on the SD card.
The same reason you should not just switch off a PC.

Always shutdown first.

OK, but shutting down does not fix the Problem. I need to delete all Logfile and then shut down to have the PSU-Plugin work properly again.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.